Closed Bug 939802 Opened 6 years ago Closed 6 years ago

JS Error: Error in adding an engine, new EngineURL: template uses invalid scheme!

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cos_flaviu, Unassigned)

References

()

Details

Environment: 
Device: Asus Transformer Tab (Android 4.0.3)
Build: Nightly 28.0a1 (2013-11-18)

Steps to reproduce:
1. Go to emag.ro;
2. Long tap on the search field;
3. From the pop-up tap on 'Add Search Engine';
4. Set the name for the search engine and tap 'OK' button;
5. Go to Settings -> Search settings;
6. Check if the search engine is installed;

Expected result:
The search engine is successfully installed.

Acutal result:
The search engine does not appear in the 'Installed Search Engines' list.

Note:
Please check out the logs:
11-18 16:57:47.800: E/GeckoConsole(8063): [JavaScript Error: "[Exception... "new EngineURL: template uses invalid scheme!"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/nsSearchService.js :: FAIL :: line 264"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/nsSearchService.js" line: 264}]
11-18 16:57:47.800: E/GeckoConsole(8063): [JavaScript Error: "NS_ERROR_FAILURE: new EngineURL: template uses invalid scheme!" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/nsSearchService.js" line: 264}]
Blocks: 852608
Flags: needinfo?(liuche)
Summary: An exception is thrown in the logcat while adding the search engine from www.emag.ro → JS Error: Error in adding an engine, new EngineURL: template uses invalid scheme!
I think this might be fixed by bug 937769. I'll land that now that the trees are open again, and we can see if that guess is correct.
Flags: needinfo?(liuche)
Depends on: 937769
The bug is still reproducible on Nightly 28.0a1 (2013-11-19).
Looks like the bug is not related to bug 937769.
Changing dependencies because this is actually unrelated to the OpenSearch work - the reporter is adding the search engine from long-tapping the search box (not urlbar).

I tried to repro this, and was able to add the search engine - flaviu, can you think of anything else that might be different about your build?
No longer blocks: 852608
Flags: needinfo?(flaviu.cos)
Looks like the bug is tablet specific.
Tested on latest nightly build:
HTC ONE X (Android 4.1.1) - Not reproducible
Google Nexus 10 (Android 4.3) - Reproducible
Flags: needinfo?(flaviu.cos)
More or less the platform, but I doubt it.
tracking-fennec: --- → ?
tracking-fennec: ? → +
Flaviu, I assume you can add other search engines like DuckDuckGo for example?
I wonder if this would be fixed by bug 790898.
Also, for more detailed error logs, you can try flipping "browser.search.log" to true in about:config, since it looks like the error happens in nsSearchService.js.
The bug is no longer reproducible.
Tested on build: Nightly 28.0a1 (2013-12-06);
Device: Asus transformer tab (Android 4.0.2);
tracking-fennec: + → ?
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.