Frequent browser_876926_customize_mode_wrapping.js | Test timed out, found a window, application timed out after 330 seconds with no output

RESOLVED FIXED in Firefox 28

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: philor, Assigned: mconley)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
Firefox 28
x86
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 unaffected, firefox28 fixed, firefox-esr24 unaffected)

Details

(Whiteboard: [Australis:P1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Odd that this managed to not fail on UX.

https://tbpl.mozilla.org/php/getParsedLog.php?id=30714162&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=30708621&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=30715063&tree=Mozilla-Inbound

Rev3 Fedora 12 mozilla-inbound debug test mochitest-browser-chrome on 2013-11-18 11:39:26 PST for push ac08f00a8ebc
slave: talos-r3-fed-082

12:07:59     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | Console message: [JavaScript Error: "A promise chain failed to handle a rejection.
12:07:59     INFO -  Date: Mon Nov 18 2013 12:07:45 GMT-0800 (PST)
12:07:59     INFO -  Full Message: [object StopIteration]
12:07:59     INFO -  Full Stack: JS frame :: resource://gre/modules/osfile/osfile_async_front.jsm :: withIterator :: line 1032
12:07:59     INFO -  JS frame :: resource://gre/modules/Promise.jsm :: <TOP_LEVEL> :: line 767
12:07:59     INFO -  JS frame :: resource://gre/modules/Promise.jsm :: <TOP_LEVEL> :: line 531
12:07:59     INFO -  native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"]
(several times, amidst GC since we're sitting and spinning)
(screenshot)
12:08:37  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | Test timed out
12:08:37     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | finished in 60054ms
12:08:37     INFO -  TEST-INFO | checking window state
12:08:37  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | Found a browser window after previous test timed out
12:08:37     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | must wait for focus
12:08:37     INFO -  --DOCSHELL 0x1005da00 == 15 [pid = 2326] [id = 1156]
12:08:44     INFO -  --DOCSHELL 0xd4c9fb0 == 14 [pid = 2326] [id = 1159]
12:08:44     INFO -  --DOCSHELL 0xdac6a28 == 13 [pid = 2326] [id = 1157]
12:08:44     INFO -  --DOCSHELL 0xa91a658 == 12 [pid = 2326] [id = 1158]
12:08:44     INFO -  --DOCSHELL 0xec3fc20 == 11 [pid = 2326] [id = 1155]
12:08:44     INFO -  --DOMWINDOW == 32 (0xb4ca3f8) [pid = 2326] [serial = 3187] [outer = 0xdaab538] [url = about:blank]
12:08:44     INFO -  --DOMWINDOW == 31 (0xc5227d0) [pid = 2326] [serial = 3188] [outer = 0xd9a6058] [url = about:blank]
12:08:44     INFO -  --DOMWINDOW == 30 (0xd9a6058) [pid = 2326] [serial = 3184] [outer = (nil)] [url = about:blank]
12:08:44     INFO -  --DOMWINDOW == 29 (0xdaab538) [pid = 2326] [serial = 3183] [outer = (nil)] [url = about:blank]
12:08:46     INFO -  --DOMWINDOW == 28 (0xb7e81c0) [pid = 2326] [serial = 3185] [outer = (nil)] [url = about:home]
12:08:46     INFO -  --DOMWINDOW == 27 (0xb295220) [pid = 2326] [serial = 3191] [outer = (nil)] [url = about:newtab]
12:08:53     INFO -  --DOMWINDOW == 26 (0xf5b3220) [pid = 2326] [serial = 3190] [outer = (nil)] [url = about:home]
12:08:53     INFO -  --DOMWINDOW == 25 (0xcfa9108) [pid = 2326] [serial = 3193] [outer = (nil)] [url = about:newtab]
12:14:23  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | application timed out after 330 seconds with no output
12:14:24     INFO -  Not taking screenshot here: see the one that was previously logged
12:14:24  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_876926_customize_mode_wrapping.js | application terminated with exit code 1536
12:14:24     INFO -  INFO | runtests.py | Application ran for: 0:18:59.023757

Comment 1

5 years ago
The error messages are sadly completely unrelated as that test doesn't touch OS.File in any way. It'd be great if we had any more info as to what breaks this. :-(
Blocks: 939862
Whiteboard: [Australis:P1]
Comment hidden (Treeherder Robot)
(Assignee)

Comment 3

5 years ago
I seem to be able to reproduce this on my Ubuntu VM. I'll investigate.
Assignee: nobody → mconley
(Assignee)

Comment 4

5 years ago
At least locally, the problem appears to be that we're waiting for the popupshown event after calling the panel's openPopup function in PanelUI.show. The event, for some reason, is never fired.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 11

5 years ago
Testing out a potential workaround: https://tbpl.mozilla.org/?tree=Try&rev=3766a22a8134
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 15

5 years ago
Created attachment 8335321 [details] [diff] [review]
Patch v1

So repeated runs of mochitest-bc are turning up green here: https://tbpl.mozilla.org/?tree=Try&rev=3766a22a8134

An explanation - at least locally, what seems to happen is that sometimes the popupshown event for the menu popup isn't being received by the promisePanelShown event handler. Not sure why that is just yet, but the problem seems to be restricted to Linux. Karl Tomlinson suggested that this might be because of a timing or focus issue where we fail to get a cursor grab, or the popup window rolls up before it has a chance to be shown.

Here's the workaround. If we land this, we should probably file a follow-up bug to investigate this weird popup behaviour.
Attachment #8335321 - Flags: review?(gijskruitbosch+bugs)

Comment 16

5 years ago
Comment on attachment 8335321 [details] [diff] [review]
Patch v1

Review of attachment 8335321 [details] [diff] [review]:
-----------------------------------------------------------------

I'll buy this for a dollar.
Attachment #8335321 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 17

5 years ago
Landed on fx-team as https://hg.mozilla.org/integration/fx-team/rev/bc43e1cf63dd
Status: NEW → ASSIGNED
Whiteboard: [Australis:P1] → [Australis:P1][fixed-in-fx-team]
(Assignee)

Comment 18

5 years ago
Filed bug 941073 about the popup issue.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/bc43e1cf63dd
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P1][fixed-in-fx-team] → [Australis:P1]
Target Milestone: --- → Firefox 28
status-firefox26: --- → unaffected
status-firefox27: --- → unaffected
status-firefox28: --- → fixed
status-firefox-esr24: --- → unaffected
You need to log in before you can comment on or make changes to this bug.