Closed Bug 940078 Opened 6 years ago Closed 6 years ago

Reload/stop button can't be moved in customization mode anymore

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: sworddragon2, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112446

Steps to reproduce:

I have noticed on the current nightly that in the customization mode the reload/stop button will be always in the address bar. Trying to move it will not work anymore as the address bar is focused.


Actual results:

The reload/stop button couldn't be moved out of the address bar.


Expected results:

The customization mode should provide a way to move the reload/stop button at another position.
Thanks for filing this bugreport. However, per the rationale in bug 755598, this was a very conscious decision, and it seems like we wouldn't just reverse course there, so I'm marking this as WONTFIX.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: Untriaged → Toolbars and Customization
Depends on: 755598
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → WONTFIX
Hm, can you tell me then how to have the reload/stop button on the left in/out of the address bar? Tabs are building up from left to right so on widescreens I have to move a much more far distance to this button now - and this isn't really funny.
(In reply to sworddragon2 from comment #2)
> Hm, can you tell me then how to have the reload/stop button on the left
> in/out of the address bar? Tabs are building up from left to right so on
> widescreens I have to move a much more far distance to this button now - and
> this isn't really funny.

You may want to consider an add-on like https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ .
Thanks, I will make a look later at this addon.
I don't want to be rude or anything but this 4chan/g/ post sums it up nicely.
https://boards.4chan.org/g/res/38146913#p38154483
(archive link when the thread 404's: http://archive.rebeccablacktech.com/g/thread/S38146913#p38154483)
You guide people who rightfully disagree with your bad decisions to fix your own mess with a third-party addons. *slow clap*
Duplicate of this bug: 940342
jaramat, I appreciate that you signed up to Bugzilla to share your thoughts on Australis, but this is not really the right place to do this.

For future commenters: could you please post your thoughts/ concerns/ ideas for improvement to the firefox-dev mailing list? You can subscribe to it here: https://mail.mozilla.org/listinfo/firefox-dev.

Note that this is a moderated list, so abuse will not be publicly posted.
Duplicate of this bug: 940497
 (In reply to :Gijs Kruitbosch from comment #1)
> Thanks for filing this bugreport. However, per the rationale in bug 755598,
> this was a very conscious decision, and it seems like we wouldn't just
> reverse course there, so I'm marking this as WONTFIX

How can you set this as WONTFIX? It doesn't matter if in bug 755598 a decision has been taken, no one of the developers has noticed that this is mainly a *usability* issue?

By putting the reload button inside the address bar you make that button one of the _SMALLEST_ button in the UI when, instead, it is one of the most used. Many users are used to open a lot of web pages that frequently refresh with that button. Even the back button is by far less used by the users that are used to open a new link in a new tab, but, on the contrary, this button is gigantic (and also makes the bar uselessly large) and again not customizable.
Duplicate of this bug: 1003069
Now that this theme is in production, will this bug be reevaluated? This is a regression in the app and seems completely at odds with the goal of making the new UI easier for people to customize.
I'm constantly searching for the reload button only to notice it's not were it used to be anymore but at an (in my opinion) totally unintuitive position.

In fact a whole lot of things that were customizable before can't be customized any longer which is a severe regression and not the "Significant new customization mode [that] makes it easy to personalize your Web experience to access the features you use the most" as it is advertised.
Don't know if you will ever change you mind, but I agree with Eduard Braun in comment #12: with this choice you are making the browser less usable for left-handed people. 

I know that there is the Classic Theme Restorer, but I do like the new theme, and I find quite absurd to install such an intrusive addon only to have *ONE* missing customization option. 

So, think about left-handed people, and please mark this bug as NEW.
Thanks a lot for your attention.
Duplicate of this bug: 1005479
Duplicate of this bug: 1027796
Duplicate of this bug: 1342729
¡Hola Gijs!

Shall this be revisited now that the reload button has seemingly made its way out of the awesome bar on https://hg.mozilla.org/mozilla-central/rev/73b3fc64525b6816842c737e104ef2ac5482d217 seemingly due to https://bugzilla.mozilla.org/show_bug.cgi?id=1363485

¡Gracias!
Alex
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to alex_mayorga from comment #17)
> Shall this be revisited now that the reload button has seemingly made its
> way out of the awesome bar on
> https://hg.mozilla.org/mozilla-central/rev/
> 73b3fc64525b6816842c737e104ef2ac5482d217 seemingly due to
> https://bugzilla.mozilla.org/show_bug.cgi?id=1363485

I don't believe so, but I also haven't worked on those changes. You should ask Dão.
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.