Closed Bug 940084 Opened 9 years ago Closed 8 years ago

Return from a navigate to 'about:*' pages on 'interactive'

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1099331

People

(Reporter: mdas, Unassigned)

References

Details

(Keywords: pi-marionette-server, Whiteboard: [affects=webqa])

We should add an exception to navigate calls (goUrl), when you navigate to about: pages since they are special and some do not go to the 'complete' document readyState even though they are done loading (like about:neterror, about:error, etc.)

This was requested from Bug 936301 and further discussed in Bug 937659
No longer blocks: 936301
Blocks: 882186
Whiteboard: [affects=webqa]
Hrm looks like we do this right now actually http://dxr.mozilla.org/mozilla-central/source/testing/marionette/marionette-listener.js#1670 via an error send. Not sure what the desired behavior is here.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1099331
You need to log in before you can comment on or make changes to this bug.