Closed Bug 940130 Opened 7 years ago Closed 7 years ago

Bookmarks drop down list animation (Nightly)

Categories

(Firefox :: Bookmarks & History, defect)

28 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 610545

People

(Reporter: dusty-2011, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P4])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131118094134

Steps to reproduce:

I press on the button to open my bookmarks in a drop down list. A short animation should appear, after which the bookmarks are visible in a drop down list. This usually goes well. However sometimes different things happen.


Actual results:

Sometimes when I press the button I don't see the short animation, but the bookmarks immediately appear (bad scenario 1). Other times when I press the button the bookmarks appear and then disappear again for half a second, after which they appear again (bad scenario 2). This may be two separate bugs, or it might be one big bug.

I have found two scenarios which make it easier to reproduce either of these bugs. Follow these steps:
1) Click on the bookmarks button
2) Click on Display all bookmarks (this opens up the bookmarks library in a new window)
3) Close the bookmarks library window with the red cross on the right corner.
4) Click on the bookmarks button again. Usually this will result in one of two bad scenarios. Either bad scenario 1 or bad scenario 2 happens. Actually I have seen a third bad scenario as well. In this third scenario the text in the first row "Display all bookmarks" gets highlighted in grey, this should not happen as well.

Or follow these steps:
1) Click on the bookmarks button
2) Click on View Bookmarks Sidebar
3) Close the bookmarks sidebar by clicking on the cross
4) Click on the bookmarks button again. This will usually result in bad scenario 1 or bad scenario 2. Sometimes I see a third bad scenario in which the text "View Bookmarks sidebar" is highlighted in grey, this should not happen either.


Expected results:

The good scenario: a short animation should appear, after which the bookmarks are visible in a drop down list.
Component: Untriaged → Bookmarks & History
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:P4]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610545
You need to log in before you can comment on or make changes to this bug.