Closed Bug 940228 Opened 7 years ago Closed 7 years ago

Australis lacks the window menus in the control bar at the top of the screen on ubuntu

Categories

(Firefox :: Theme, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 619899

People

(Reporter: adrianm2, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131118094134

Steps to reproduce:

1)Boot Ubuntu
2)Start with a new profile
3)Move mouse to the control bar at the top of the screen.


Actual results:

No window menus in the control bar


Expected results:

Window menus should appear in the control bar, like all other applications.
For our own builds we never have shown the main menu in the global bar but inside the Firefox window itself. Now with Australis you will have to press the Alt button to show the menu, similar to what the behavior on Windows is. So this might be expected.

But pressing Alt conflicts with the global setting under Ubuntu, which brings up the run command overlay.
Component: Untriaged → Theme
Hardware: x86_64 → All
Depends on: 896887
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ubuntu bundles an add-on which clones our (hidden) menubar out to dbusmenu so that we work properly with the global menu bar.

Yes, our hiding of the menubar on Linux is by design, as per bug 896887. Marking this one as WONTFIX.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 619899
You need to log in before you can comment on or make changes to this bug.