Closed Bug 940286 Opened 6 years ago Closed 6 years ago

Australis bookmarks menu does not highlight on typing

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: bj, Assigned: mbrubeck)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P4][good first verify])

Attachments

(2 files)

Steps to reproduce:
1) Click the bookmarks menu button.
2) Type "M".
3) Press the right arrow key.

Expected result:
The "Mozilla Firefox" entry is highlighted in step 2.

Actual result:
No visual sign that Firefox has noticed the typing in step 2, but the menu does open in step 3.
Whiteboard: [Australis:P4]
This behavior occurs if the item is a link or a bookmarks folder with no sub-folders. Bookmarks folders with sub-folders get highlighted by typing.
Attached patch patchSplinter Review
Keyboard navigation of menus sets the [_moz-menuactive] attribute.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #8363992 - Flags: review?(jaws)
Using this selector for both toolbarbuttons and menuitems is kind of a mess...
Component: Toolbars and Customization → Theme
Comment on attachment 8363992 [details] [diff] [review]
patch

Review of attachment 8363992 [details] [diff] [review]:
-----------------------------------------------------------------

It would be great to clean up the toolbarbutton/menuitem mess that we have with the menu panel and subviews, but I don't expect that to happen anytime soon.
Attachment #8363992 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/0592b1488a8a
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0592b1488a8a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 29
This needs to be backed out, because `_moz_menuactive == "true"` on mouse hover. This causes the menu items on mouse hover to receive the ACTIVE button styling, which is darker than the HOVER styles.

In other words, this is not the right fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch follow-up patchSplinter Review
Good catch, thanks.  This patch (when applied on top of the first one) applies "hover" styling instead of "active" styling for [_moz-menuactive="true"] menuitems.
Attachment #8366068 - Flags: review?(mdeboer)
Backed out: https://hg.mozilla.org/integration/fx-team/rev/3021d13c9cff

(pending review and checkin of updated patch)
Comment on attachment 8366068 [details] [diff] [review]
follow-up patch

Review of attachment 8366068 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing this review. This won't apply cleanly anymore now that it's been backed out, but the gist of this is sound. I trust your rebasing skills. r=me.
Attachment #8366068 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/integration/fx-team/rev/4b86247721b2
Status: REOPENED → ASSIGNED
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/4b86247721b2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Whiteboard: [Australis:P4] → [Australis:P4][good first verify]
You need to log in before you can comment on or make changes to this bug.