Closed Bug 940320 Opened 7 years ago Closed 2 years ago

When the tab bar is collapsed (e.g. in popup windows), the navigation toolbar shouldn't have a white gradient in its background

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
normal
Points:
2

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: fb+mozdev, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P4-])

Attachments

(1 file)

See attachments for classic vs. Australis popup. 

STR:
1. Visit http://www.popuptest.com/goodpopups.html
2. Click on first link, a popup should appear. 
3. Compare with screenshots resp. Classic theme.

Result: 
The chrome background does not extend to the nav-bar, instead it's a light gray with no transition zone or border. 

Expected:
Styling of popups in Australis should remain the same as in Classic, or (better, but requires more vertical space) should adopt the Australis nav-bar styling.
Mike, would your patch in bug 930094 fix this?
Flags: needinfo?(mconley)
(In reply to :Gijs Kruitbosch from comment #1)
> Mike, would your patch in bug 930094 fix this?

Hm, it doesn't as of yet. I think we should keep this bug open to make sure we don't regress this.
Flags: needinfo?(mconley)
Whiteboard: [Australis:P4][Australis:M?]
Duplicate of this bug: 944606
Whiteboard: [Australis:P4][Australis:M?] → [Australis:P4-]
Duplicate of this bug: 992273
Flags: firefox-backlog+
Summary: [Australis] popup navigation toolbar lost background → When the tab bar is collapsed (e.g. in popup windows), the navigation toolbar shouldn't have a white gradient in its background
Whiteboard: [Australis:P4-] → [Australis:P4-] p=2
Whiteboard: [Australis:P4-] p=2 → [Australis:P4-] p=2 [qa+]
Version: 28 Branch → Trunk
Points: --- → 2
QA Whiteboard: [qa+]
Whiteboard: [Australis:P4-] p=2 [qa+] → [Australis:P4-]
I don't think this is relevant since the Photon redesign, but feel free to reopen if it is.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.