Closed Bug 940540 Opened 11 years ago Closed 11 years ago

Bring back the Firefox/app button

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 870634

People

(Reporter: landis, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131119030202

Steps to reproduce:

1: updated Nightly (twice) this morning.
2: restart


Actual results:

1: on restart, 'Firefox button' (tab menu button) is Missing
2: second quite, start: 'Tabs on Top' - HATE this 'option'


Expected results:

1: Firefox button should be on the left of my Tabs in the Tabs Bar
2: My tabs should be on 'bottom', or at the Top of My Page Window.
about:config
browser.tabs.onTop is set to false, yet tabs are on top.

This is a Bad design. the page and their tabs are used more than anything else, even by me, someone who bookmarks several pages a day..
Component: Untriaged → Toolbars and Customization
Landis, you mean you'd like to have your tabs back at the bottom of the toolbar that contains the urlbar and back/forward buttons?

I'm not really sure what you mean with 'Firefox button'. Could you perhaps post a screenshot of what you're seeing/ missing?
(In reply to Mike de Boer [:mikedeboer] from comment #2)
> Landis, you mean you'd like to have your tabs back at the bottom of the
> toolbar that contains the urlbar and back/forward buttons?

verses 'Tabs on Top'.. Tabs should be directly above 'page' window and NOT above the other toolbars.
> 
> I'm not really sure what you mean with 'Firefox button'. Could you perhaps
> post a screenshot of what you're seeing/ missing?

I don't know what else to call it. I've only seen it referred to as the 'firefox button'. It is the button on the left edge of the Tabs Bar, when Menu Bar is 'hidden' (disabled).

I hope this helps.
Landis.
p.s., with the help of 'Fank' at MozillaZine last night, I was able to add code snippet to userChrome.css to get my 'Tabs on Bottom'

[code]
/*Frank Tabs back to Bottom.... added 19.11.13 - Landis*/
#TabsToolbar {
-moz-box-ordinal-group: 2 !important;
}
#addon-bar {
-moz-box-ordinal-group: 3 !important;}
[/code]
http://forums.mozillazine.org/viewtopic.php?f=23&t=2773199&p=13199573#p13199573
mikedeboer, forgot to mention. the 'Firefox Button' will say Firefox, Aurora or Nightly, depending on which release I'm running. The image i uploaded is a clip for an earlier 28.0a1 screenshot I took. Current 28.0a1 is missing it. That's another issue... mozilla's versioning scheme ... Todays Nightly should have been and would have been anywhere else, a New Major Version Number Increase.... There was not even a minor version number changes... That, I don't get. All add-ons and themes were affected, hence Major version change!

Landis.
(In reply to Landis Reed from comment #4)
> mikedeboer, forgot to mention. the 'Firefox Button' will say Firefox, Aurora
> or Nightly, depending on which release I'm running. The image i uploaded is
> a clip for an earlier 28.0a1 screenshot I took. Current 28.0a1 is missing
> it.

Ah, thanks for the screenshot! That MUST taken on a Windows machine. Since the bug says 'Platform: x86/ Linux' I assumed you filed this bug for the Linux version.

In the case of the Windows version: the 'Firefox' button has been removed in favor of the new Menu Button on the far right next to the url bar. There you'll find all the necessary tools.

> That's another issue... mozilla's versioning scheme ... Todays Nightly
> should have been and would have been anywhere else, a New Major Version
> Number Increase.... There was not even a minor version number changes...
> That, I don't get. All add-ons and themes were affected, hence Major version
> change!

I think you need to understand that version numbers are increased for Nightlies BEFORE any new code & features are checked in. This means that the changes for a certain version are not set in stone until they move on to the Beta channel. This also means that the Australis changes are not set in stone to travel with version 28! Of course we hope it will and do our best to fix as many bugs as possible to make that happen!

Landis, we really appreciate your feedback, thanks!
(In reply to Mike de Boer [:mikedeboer] from comment #5)
> (In reply to Landis Reed from comment #4)
> > mikedeboer, forgot to mention. the 'Firefox Button' will say Firefox, Aurora
> > or Nightly, depending on which release I'm running. The image i uploaded is
> > a clip for an earlier 28.0a1 screenshot I took. Current 28.0a1 is missing
> > it.
> 
> Ah, thanks for the screenshot! That MUST taken on a Windows machine. Since
> the bug says 'Platform: x86/ Linux' I assumed you filed this bug for the
> Linux version.
> 
> In the case of the Windows version: the 'Firefox' button has been removed in
> favor of the new Menu Button on the far right next to the url bar. There
> you'll find all the necessary tools.

This is true even on Linux. If you hide the menubar there, we show the app button (at least on Gnome 3, where I'm checking). I've adjusted the summary accordingly. Let's leave this open for now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: firefox button missing in 19,11.13 Nightly (tab menu button) → Bring back the Firefox/app button
(In reply to :Gijs Kruitbosch from comment #6)
> If you hide the menubar there, we show the app button.

Ugh, this wasn't clear. We *used* to show the app button (on e.g. current stable/beta/aurora). The decision to remove it on Nightly was a conscious one.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
I Am on Linux, openSuSE 12.3.x, KDE 4.11.x 
The 'App button' was VERY Convenient!
It, in my opinion, should be PUT Back... 
Please.

Landis.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: