Right clicking on toolbar and clicking Customize brings up an empty page

RESOLVED DUPLICATE of bug 940946

Status

()

RESOLVED DUPLICATE of bug 940946
5 years ago
5 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR: 1. Right click on the toolbar.
2. Click Customize.

I see about:customizing being opened as an empty tab with the following source:

<?xml version="1.0" encoding="UTF-8"?>
<!-- This Source Code Form is subject to the terms of the Mozilla Public
   - License, v. 2.0. If a copy of the MPL was not distributed with this
   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->

<!DOCTYPE html [
  <!ENTITY % htmlDTD
    PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "DTD/xhtml1-strict.dtd">
  %htmlDTD;
  <!ENTITY % brandDTD SYSTEM "chrome://branding/locale/brand.dtd">
  %brandDTD;
  <!ENTITY % browserDTD SYSTEM "chrome://browser/locale/browser.dtd">
  %browserDTD;
]>

<html xmlns="http://www.w3.org/1999/xhtml"
      disablefastfind="true">
	<head>
		<title>&customizeMode.tabTitle;</title>
	</head>
	<body></body>
</html>

There is an error reported to the browser console:

shareButton is null browser.js:5258

The code being:


  update: function() {
    let shareButton = this.shareButton;
    shareButton.hidden = !SocialUI.enabled ||
                         [p for (p of Social.providers) if (p.shareURL)].length == 0;
    shareButton.disabled = shareButton.hidden || !this.canSharePage(gBrowser.currentURI);

    // also update the relevent command's disabled state so the keyboard
    // shortcut only works when available.
    let cmd = document.getElementById("Social:SharePage");
    cmd.setAttribute("disabled", shareButton.disabled ? "true" : "false");
  },

It seems like shareButton on the first line is null.
(Reporter)

Comment 1

5 years ago
Created attachment 8335299 [details]
about:support
(Reporter)

Comment 2

5 years ago
Note that I have customized Firefox to remove the share button.
Blocks: 939862

Comment 3

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> Note that I have customized Firefox to remove the share button.

To remove it how/where?
(Reporter)

Comment 4

5 years ago
(In reply to comment #3)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> > Note that I have customized Firefox to remove the share button.
> 
> To remove it how/where?

Not sure what you mean.  I dragged it out of my toolbar through the customize mode.

Comment 5

5 years ago
Is the share button currently meant to be removable, Shane? If not, this is a dupe of bug 940946. If it is, this is probably a Social API bug.

The number of issues with entering/exiting customize mode is disconcerting, so I'll file a general bug about hardening that code to better deal with random exceptions (although that's going to make for ugly code and such, it'll make our UI not break as much).
Flags: needinfo?(mixedpuppy)
(In reply to :Gijs Kruitbosch from comment #5)
> Is the share button currently meant to be removable, Shane? If not, this is
> a dupe of bug 940946. If it is, this is probably a Social API bug.

No, the share button is not meant to be movable for now.  We can revisit that later, but it is a more complex UI that wont easily conform to the menu panel.

Shane
Flags: needinfo?(mixedpuppy)

Comment 7

5 years ago
Alright, so I guess that makes this a dupe then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940946
You need to log in before you can comment on or make changes to this bug.