[Messages] Follow up Bug 919966 - Ensure that forwarding a MMS with a subject fills in the subject in the composer

VERIFIED FIXED in Firefox OS v1.3

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: julienw, Assigned: fcampo)

Tracking

unspecified
1.3 C3/1.4 S3(31jan)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

When dependent bugs will be fixed, this bug will ensure that we can forward a MMS with a subject.
Just tried this, and it doesn't seem to work.

Asking 1.3 and flagging Fernando then.
blocking-b2g: --- → 1.3?
Flags: needinfo?(fernando.campo)

Comment 2

5 years ago
Hi Fernando,

Could you please confirm whether this issue is a bug and not a pending development task?

If this is a bug, it would be the only open bug depending on bug 919966 (the US) so we could Resolved/Fixed it and start the 'official' testing.

Thanks.
triage: 1.3+, for not forwarding a message with the subject
blocking-b2g: 1.3? → 1.3+

Updated

5 years ago
Summary: [Messages] Ensure that forwarding a MMS with a subject fills in the subject in the composer → [Messages] Follow up Bug 919966 - Ensure that forwarding a MMS with a subject fills in the subject in the composer
(Assignee)

Comment 4

5 years ago
Checking!
Assignee: nobody → fernando.campo
Flags: needinfo?(fernando.campo)
(Assignee)

Comment 5

5 years ago
after checking the code, my opinion is that this is a pending development task, not included in any existing bug at the time.
Will try to make a patch for today.
(Assignee)

Comment 6

5 years ago
Created attachment 8347242 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/14653

...like this one
Attachment #8347242 - Flags: review?(borja.bugzilla)
Attachment #8347242 - Flags: feedback?(felash)
Comment on attachment 8347242 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/14653

looks good, but this needs tests ;)
Attachment #8347242 - Flags: feedback?(felash) → feedback+
Some comments to address! Let me know when you are ready!
status-b2g-v1.3: --- → affected
I've just reviewed this as well and there are several issues that need to be addressed.
(In reply to Rick Waldron [:rwaldron] from comment #9)
> I've just reviewed this as well and there are several issues that need to be
> addressed.

To be more specific, please make the following changes: 

- https://github.com/mozilla-b2g/gaia/pull/14653/files#diff-74841e428dea67f7357f1893a4d26155R409
- https://github.com/mozilla-b2g/gaia/pull/14653#discussion_r8483505
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)

Comment 11

5 years ago
PM triaged this bug and believes that it should be a blocker.
Target Milestone: 1.3 C2/1.4 S2(17jan) → 1.3 C3/1.4 S3(31jan)
Attachment #8347242 - Flags: review?(borja.bugzilla) → review+
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 4df4a5b17839fc6ce748029fc1e79bb2bde3cc87
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(fernando.campo)
(Assignee)

Comment 14

5 years ago
Done -> cb6280606e1a306b13bb48e45fb3fcd940ff9f71
Flags: needinfo?(fernando.campo)
status-b2g-v1.3: affected → fixed
Tested (01/28/14)
1.3
Gecko 605c25a
Gaia 3c51195
Status: RESOLVED → VERIFIED
Hey Fernando, the uplift in v1.3 broke the unit tests, can you please do a pull request to fix it?

see https://travis-ci.org/mozilla-b2g/gaia/jobs/17696495

Otherwise I'll have to back out this and I'd rather not to :(
Flags: needinfo?(fernando.campo)
(Assignee)

Comment 17

5 years ago
Argh, didn't check the tests, my mistake.

I'll take a look, but probably tomorrow as I'm super busy right now.
Flags: needinfo?(fernando.campo)
Ok, I'll fix it and ask you a review :)
Created attachment 8366737 [details] [review]
fix unit tests on v1.3 - github pr
Attachment #8366737 - Flags: review?(fernando.campo)
Comment on attachment 8366737 [details] [review]
fix unit tests on v1.3 - github pr

Rick, if you have some time to have a look at this simple patch to put some more green to the v1.3 branch?
Attachment #8366737 - Flags: review?(waldron.rick)
Looks like a failure in compose_test.js https://travis-ci.org/mozilla-b2g/gaia/jobs/17782781
oh right, missed that.
Taking a look!
Ok, the uplift includes some Draft stuff which does not exist in 1.3. Gonna back out and uplift again.
Reverted on v1.3: 622324f673a18103eeb05e69c2c6092e972f2513
status-b2g-v1.3: fixed → affected
Ping me when ready :)
Created attachment 8366824 [details] [review]
v1.3 github PR

I still need to test this on the device.
Attachment #8366737 - Attachment is obsolete: true
Attachment #8366737 - Flags: review?(waldron.rick)
Attachment #8366737 - Flags: review?(fernando.campo)
Comment on attachment 8366824 [details] [review]
v1.3 github PR

Tested on the device, itgo ga works as expected.
Now waiting for a green travis.
Comment on attachment 8366824 [details] [review]
v1.3 github PR

Would be more comfortable with a second look.

Basically, I removed everything that concerned Drafts from the original patch, since v1.3 doesn't do drafts.
Attachment #8366824 - Flags: review?(waldron.rick)
Comment on attachment 8366824 [details] [review]
v1.3 github PR

Tested on a device and works as expected! r=me

There are some JSHint issues, but I don't think they are yours (I think these are the pre-existing issues we've since resolved.) These are out of scope for this ticket.
new uplift to v1.3: 1b65a46b59c732f35aded5f891593362c5e4621d

Thanks Rick !
status-b2g-v1.3: affected → fixed
(Assignee)

Comment 31

5 years ago
Thanks for fixing it guys, sorry for not being of much help :(
Tested (01/30/2014) and working
1.3
Gecko 8687e17
Gaia 8defa5b
See Also: → bug 980230
Duplicate of this bug: 980230
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Attachment #8366824 - Flags: review?(waldron.rick)
You need to log in before you can comment on or make changes to this bug.