Marionette uses "deleteSession" for ending sessions while the expected webdriver command is "quit". This incompatibility makes it harder to use Marionette directly without maintaining a WebDriver-to-Marionette command conversion set.
Since Marionette doesn't manage the life cycle of the browser itself, it might be confusing to rename deleteSession to quit when quit needs special casing in each language bindings anyways. Keeping startSession and deleteSession as they are makes more sense IMO.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.