Closed Bug 941137 Opened 6 years ago Closed 6 years ago

Alter plugin defaults for beta/release until whitelist strategy is defined

Categories

(Core :: Plug-ins, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla28
Tracking Status
firefox26 + verified
firefox27 --- verified
firefox28 --- verified
b2g-v1.2 --- fixed

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file)

For Fx26 and probably 27, we have decided to hold off turning on click-to-activate for all plugins. This will give Chad Weiner a chance to define a whitelisting strategy for plugin vendors who are making a transition to HTML5 technologies but need additional time to complete that transition. So for now, we're going to flip the plugin default state to activated, and explicitly change Java to be click-to-activate.
Attached patch bug941137Splinter Review
This is a patch for all channels, using RELEASE_BUILD to set the correct prefs.
Attachment #8335490 - Flags: review?(georg.fritzsche)
Attachment #8335490 - Flags: approval-mozilla-beta?
Attachment #8335490 - Flags: approval-mozilla-aurora?
Comment on attachment 8335490 [details] [diff] [review]
bug941137

Review of attachment 8335490 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Attachment #8335490 - Flags: review?(georg.fritzsche) → review+
Attachment #8335490 - Flags: approval-mozilla-beta?
Attachment #8335490 - Flags: approval-mozilla-beta+
Attachment #8335490 - Flags: approval-mozilla-aurora?
Attachment #8335490 - Flags: approval-mozilla-aurora+
Adding Juan as QA to make sure this gets tested on Thursday's beta 7
Keywords: verifyme
QA Contact: jbecerra
https://hg.mozilla.org/integration/fx-team/rev/cb500491e8a5

Setting checkin-needed for branches.
Keywords: checkin-needed
Target Milestone: --- → mozilla28
https://hg.mozilla.org/mozilla-central/rev/cb500491e8a5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified as fixed with Firefox 26 beta 7 (build ID: 20131122094025) on: Win 7 64-bit, XP 32-bit, Mac OS X 10.7 and Ubuntu 12.04 32-bit: Java is the only click-to-activate plug-in. 

Please see here for more details: https://etherpad.mozilla.org/firefox26b7-testing
Verified as fixed using Firefox 27 beta 1 on Windows 8.1 x64, Windows XP x32, Ubuntu 13.04 x64, Mac OS X 10.7. Java is the only click-to-activate plug-in. The plugins that were tested are stated in the etherpad from comment 8.
Verified as fixed using Firefox 28 beta 2 on Windows 7 x64, Windows XP x64, Ubuntu 13.04 x64, Mac OS X 10.8. Java is the only click-to-activate plug-in. The plugins that were tested are stated in the etherpad from comment 8.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.