Closed Bug 941155 Opened 6 years ago Closed 2 years ago

fix talos on mobile to have pageloader tests working in regular mode and nochrome mode

Categories

(Testing :: Talos, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: talos-android)

Currently our pageloader tests load pages in the gecko layer and we never display them on the screen via the java frontend.

We should call out what we want to test specifically in this bug and make it happen.

My understanding is we want:
1) noChrome using geckoview
2) full mode which displays in a normal UI
3) not load about:home?

For option 1 there will be some fun work to get this apk installed by releng.  We would need to figure out how to get the addon installed (either pageloader or some bootstrap variation thereof).

Option #2 could work today by loading a bootstrap addon that manages the frontend browser and opens a tab in the frontend.  This tab could then work with the pageloader addon to drive the URI's and display them properly.

item #3 references us loading about:home in talos tests which pulls in a lot of code and work that is unrelated to the test we are testing.  Do we want to remove this feature?  if so we need a method for making fennec load about:blank or something equivalent
(In reply to Joel Maher (:jmaher) from comment #0)
> Currently our pageloader tests load pages in the gecko layer and we never
> display them on the screen via the java frontend.

Just adding that according to joel on IRC, it's been this way since dec-2011. We practically don't render any of the pageloader "test subjects" to screen.
blassey- can you chime in here with what we really should be testing on android.
Flags: needinfo?(blassey.bugs)
My suggestion was to run "no-chrome" tests in the GeckoView embedding example app that just landed in bug 930072.
Flags: needinfo?(blassey.bugs)
blassey, so there is no need for chrome view in the full fennec app?
ideal situation:
geckoview for tsvgx and tp4_mobile
full fennec for tp4_mobile

That is 3 tests.

Now to work on geckoview locally and then get releng to deploy it.  In the meantime I can work on pageloader chrome mode for android.
Depends on: 944041
Duplicate of this bug: 947393
Now that geckoviewexample builds, I'll be looking to get it to install addons, where jmaher said he should be able to take over (using the talos addon).
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
bug 985610 prevents geckoview_example from building.
Depends on: 985610
Whiteboard: talos-android
:mcomella, any issues with closing this as we are moving android talos -> autophone?
(In reply to Joel Maher (:jmaher) from comment #9)
> :mcomella, any issues with closing this as we are moving android talos ->
> autophone?

We should change this bug to be focused on autophone then (or open a new one with the same intent) - a non-chrome vs. chrome benchmark would be still useful.

That being said, I'm not actively working on this.
Assignee: michael.l.comella → nobody
Status: ASSIGNED → NEW
closing out old bugs that haven't been a priority
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.