expand our support for the Vary header

RESOLVED FIXED

Status

()

enhancement
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: darin.moz, Assigned: bjarne)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
mozilla does not fully implement the Vary header.  we are not violating the spec
with our implementation, but we are also not taking advantage of it either.

we should really be storing the value's of the request headers, specified by
Vary response header, in the cache entry's meta data.  then when making a new
request for the same URL, we'd be able to compare the request headers to see if
the cached response could be used.

currently, we just ignore a cached response that contains a Vary header matching
request headers that could change, either via prefs or some API.  but, the
headers we compare are hardcoded and this prevents our Vary header support from
being dynamic -- ie. based on the headers that we really do send.
(Reporter)

Comment 1

18 years ago
-> future
Target Milestone: --- → Future

Comment 2

17 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement

Updated

17 years ago
Summary: [RFE] expand our support for the Vary header → expand our support for the Vary header
how does this bug relate to bug 132957? Is it a duplicate?

Comment 4

16 years ago
Darin, looking at the current code it allready seems to the above.
This can be closed?

Updated

16 years ago
QA Contact: tever → httpqa

Comment 5

15 years ago
*** Bug 236718 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
I posted bug #236718, turns out it was a duplicate of this bug.

It would be nice if Mozilla supported "Vary: Cookie".  Currently, no major
browser supports this correctly.  Mozilla treats it like "Vary: *", which
doesn't break the specification, but hampers caching in dynamic pages (pages
always require re-validation).
(Reporter)

Comment 7

13 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
Target Milestone: Future → ---
(Assignee)

Comment 8

10 years ago
I'll grab this as a followup to bug #510359
Assignee: nobody → bjarne
(Assignee)

Comment 9

9 years ago
I'm closing this one since bug #468426 landed. Let's handle special cases in separate bugs.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.