incomplete LDAP subtree search

VERIFIED INVALID

Status

MailNews Core
LDAP Integration
--
major
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: kjellk, Assigned: Srilatha Moturi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

I'm working on a LDAP server with a personal and company addressbook located in
uid='entries',ou=addressbook,uid='myuser',o='mycompany' and     
uid='entries',ou=addressbook,o='mycompany' respectively. When searching with the
subtree enabled, entries in these addressbooks aren't found. Entries in
uid='entries',o=mycompany are found just fine.

Reproducible: Always
Steps to Reproduce:
1. use the autocompletion in the mail composer
2.
3.

Actual Results:  entries are not found

Expected Results:  they should have been found

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 17879 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Srilatha and myself don't  agree this is dup of  bug 17879.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
kjellk: can you find all the lines with the string "ldap_2" in your prefs.js
file, and paste them into this bug?  That will help us better understand what's
going on.
Summary: inclomplete LDAP subtree search → incomplete LDAP subtree search
(Reporter)

Comment 4

17 years ago
I probably made a mistake here. Since the LDAP-client uses an anonymous login?
it has not got the rights to see anything down the tree :-( Sorry...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.