UITour: Disable on pre-australis builds

VERIFIED FIXED in Firefox 27

Status

()

Firefox
General
P5
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Unfocused, Assigned: Unfocused)

Tracking

unspecified
Firefox 27
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 verified, firefox28 affected, firefox29 wontfix)

Details

Attachments

(1 attachment)

Looks like we won't be using this on anything before Australis, so may as well flip the switch to disable it. Easy enough to flip the pref back for testing.
Created attachment 8335744 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 862998
User impact if declined: A page on mozilla.org may activate a sub-standard and unfinished tour experience (we don't see the need to backport fixes to Aurora any more)
Testing completed (on m-c, etc.): None needed - disabling a purely additive feature
Risk to taking this patch (and alternatives if risky): None. Alternative is leave it disable (low impact, but unfinished feature), or a full backout (low impact, but messier than just disabling)
String or IDL/UUID changes made by this patch: None
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attachment #8335744 - Flags: review?
Attachment #8335744 - Flags: approval-mozilla-aurora?
Priority: -- → P5

Updated

4 years ago
Attachment #8335744 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
status-firefox26: --- → unaffected
status-firefox27: --- → affected
Keywords: verifyme
https://hg.mozilla.org/releases/mozilla-aurora/rev/f403af8356f9

Leaving this open because I assume we're going to want this landed on Aurora again for Fx28 after the next merge. Alternatively, we could just land this on Holly now and be done with it.
status-firefox27: affected → fixed
status-firefox28: --- → affected
status-firefox29: --- → wontfix
Target Milestone: --- → Firefox 27
Found out it is indeed safe to land this directly on Holly, so:
https://hg.mozilla.org/projects/holly/rev/aca9247177d8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 4

4 years ago
Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

Verified as fixed on Firefox 27 beta 2 (Build ID: 20131216183647): the
browser.uitour.enabled pref is present in about:config and set to false
by default.
Is anything else that QA can manually test here?
Flags: needinfo?(bmcbride)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #4)
> Is anything else that QA can manually test here?

Nope, everything else is covered by unit tests. Thanks!
Flags: needinfo?(bmcbride)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.