If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove deprecated functions of mozKeyboard API

RESOLVED DUPLICATE of bug 986992

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 986992
4 years ago
4 years ago

People

(Reporter: yxl, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

mozKeyboard API is currently restricted to the internal usage for the gaia system app only. The embedded gaia keyboard app and the third party keyboard app are switched to use the InputMethod API instead.

To reduce the efforts of maintenance of the deprecated mozKeyboard API and improving the new IinputMethod API. I think we should remove the unused functions of mozKeyboard API as well as the workaround code to make InputMethod API compatible with mozKeyboard API.

After removal, the following the functions of the mozKeyboard will be kept:

interface nsIB2GKeyboard : nsISupports
{
  void setSelectedOption(in jsval index);

  void setSelectedOptions(in jsval indexes);

  void setValue(in jsval value);

  void removeFocus();
};
removeFocus can be easily replaced by mozInputMethod (there are two places where we use it a.t.m.). The other methods need a new API in input method.
Created attachment 8350912 [details] [diff] [review]
patch v1

https://tbpl.mozilla.org/?tree=Try&rev=3e1263d50397
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986992
You need to log in before you can comment on or make changes to this bug.