Closed Bug 941637 Opened 8 years ago Closed 8 years ago

App icons don't have alt text so screen readers can't read them

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S1 (14feb)
blocking-b2g -
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: MarcoZ, Assigned: amirn)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
ranbena
: review+
Details | Review
STR:
1. Turn on Screen Reader in Developer Settings.
2. Return to the first Home Screen.
3. Tap on Social so it gets the highlight, then double-tap.
4. Explore the items, either by touching them or by swiping left and right.

Result: Except for the "Social" header, all graphics are unlabeled. The only thing the screen reader says is "Graphic". A blind user has no way of knowing which icon does what.

The graphics need alternative text associated with them, and this text must be localizable.
Assignee: nobody → yosef
Summary: Items in the "Social" folder are unlabeled for accessibility → App icons don't have alt text so screen readers can't read them
Amir, plz add alt="{app name}" to the result icon and result text images.
Assignee: yosef → amirn
Status: NEW → ASSIGNED
Attached file Redirect to PR (obsolete) —
Added 'aria-label' property to E.me results
(this is how it's done in the homescreen app
https://github.com/EverythingMe/gaia/blob/master/apps/homescreen/js/page.js#L115)
Attachment #8351002 - Flags: review?(ran)
Comment on attachment 8351002 [details]
Redirect to PR

Doesn't work well for some result types.

1. Download suggestions label should have a "download" prefix
2. Marketplace search label is "undefined"
Attachment #8351002 - Flags: review?(ran) → review-
(In reply to Ran Ben Aharon (Everything.me) from comment #3)
> Comment on attachment 8351002 [details]
> Redirect to PR
> 
> Doesn't work well for some result types.
> 
> 1. Download suggestions label should have a "download" prefix
> 2. Marketplace search label is "undefined"

fixed and updated PR
Still getting aria-label="undefined" for marketsearch
Attached file Redirect to PR
Attachment #8351002 - Attachment is obsolete: true
Comment on attachment 8351331 [details] [review]
Redirect to PR

Looking good.
Attachment #8351331 - Flags: review+
landed: https://github.com/mozilla-b2g/gaia/commit/8d28c71
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 1.3?
Screen reader is an off by default feature, so that makes this a non-blocker for the release. Feel free to ask for approval though.
blocking-b2g: 1.3? → -
Attachment #8351331 - Flags: approval-gaia-v1.3?
Note - you need to fill out the approval form.
Requesting approval for 1.3

Caused by:
Never implemented

User impact:
Screen reader can not read Everything.me search results and inside Collections

Risk:
Low

Changes made:
Added 'aria-label' attribute to Everything.me results
Comment on attachment 8351331 [details] [review]
Redirect to PR

Approving gaia-v1.3: This fix enhances search results per comment 11
Attachment #8351331 - Flags: approval-gaia-v1.3? → approval-gaia-v1.3+
v1.3: 4fb7a107c8ccd9fef5f715b545416ac9700d0a87
Target Milestone: --- → 1.4 S1 (14feb)
You need to log in before you can comment on or make changes to this bug.