Closed Bug 941770 Opened 11 years ago Closed 10 years ago

newSession should have an option to connect to existing tab

Categories

(Remote Protocol :: Marionette, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1046512

People

(Reporter: mdas, Unassigned)

Details

I can't remember why we did this, but it's not in the spec and doesn't seem necessary.
From today's WebDriver face-to-face, it will be in the spec, but we can add a way to implement this.
Although, we don't quite follow spec. We're to start a unique browser instance, so I filed https://bugzilla.mozilla.org/show_bug.cgi?id=976807 to change our default behaviour.
Summary: newSession shouldn't create new tab → newSession should have an option to connect to existing tab
We changed this in bug 1046512 because it was coincidentally an e10s-friendly to re-use the current open tab, although this doesn't address the bug mentioned in comment 3.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Product: Testing → Remote Protocol
You need to log in before you can comment on or make changes to this bug.