configure errors with android v19, cannot find dx

VERIFIED FIXED in Firefox 28

Status

()

Firefox for Android
General
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: retornam, Unassigned)

Tracking

unspecified
Firefox 28
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I followed the steps in
https://wiki.mozilla.org/Mobile/Fennec/Android for MacOS X and I got an error when I tried ./mach build. "dx" was not found when using the Android SDk version 19.
(Reporter)

Comment 1

4 years ago
Created attachment 8336386 [details] [diff] [review]
bug941889.patch
(Reporter)

Updated

4 years ago
Attachment #8336386 - Flags: review?(nalexander)
Attachment #8336386 - Flags: review?(luke)

Comment 2

4 years ago
Comment on attachment 8336386 [details] [diff] [review]
bug941889.patch

I'm sorry, I'm really not the person to review this type of change.  I did run into this issue once in another bug (maybe that's what you found), but it was fixed by a patch in that bug.
Attachment #8336386 - Flags: review?(luke)
New patches in original bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 905315
Comment on attachment 8336386 [details] [diff] [review]
bug941889.patch

Review of attachment 8336386 [details] [diff] [review]:
-----------------------------------------------------------------

Sigh.  This is tedious.

r=nalexander, bug pleese format the commit line like:

Bug 941889 - Make configure recognize Android 19 tools. r=nalexander
Attachment #8336386 - Flags: review?(nalexander) → review+
I'd like to get this in under a separate bug number, so re-opening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
> r=nalexander, bug pleese format the commit line like:

But please.
(Reporter)

Comment 7

4 years ago
(In reply to Nick Alexander :nalexander from comment #6)
> > r=nalexander, bug pleese format the commit line like:
> 
> But please.

Thanks. I'll change the commit message and submit a new patch
(In reply to raymond [:retornam] (needinfo? me) from comment #7)
> (In reply to Nick Alexander :nalexander from comment #6)
> > > r=nalexander, bug pleese format the commit line like:
> > 
> > But please.
> 
> Thanks. I'll change the commit message and submit a new patch

Do you have commit access?  If not, I'll land the patch for you, and I can update the commit message.
(Reporter)

Comment 9

4 years ago
(In reply to Nick Alexander :nalexander from comment #8)
> (In reply to raymond [:retornam] (needinfo? me) from comment #7)
> > (In reply to Nick Alexander :nalexander from comment #6)
> > > > r=nalexander, bug pleese format the commit line like:
> > > 
> > > But please.
> > 
> > Thanks. I'll change the commit message and submit a new patch
> 
> Do you have commit access?  If not, I'll land the patch for you, and I can
> update the commit message.
I dont have commit access, please update and land. Thanks
https://hg.mozilla.org/integration/mozilla-inbound/rev/957e0c3927a1
Assignee: nobody → mozbugs.retornam
Status: REOPENED → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/957e0c3927a1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
(Reporter)

Comment 12

4 years ago
Thanks everyone.
Status: RESOLVED → VERIFIED

Comment 13

4 years ago
Sorry this breaks again because build-tools 19.0.1 is out now :-(
Depends on: 960640
(Reporter)

Updated

4 years ago
Assignee: mozbugs.retornam → nobody
You need to log in before you can comment on or make changes to this bug.