Closed Bug 94228 Opened 19 years ago Closed 9 years ago

Can lock up browser if quota exceeded when dialog presented in mailnews

Categories

(SeaMonkey :: MailNews: Backend, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: slogan, Unassigned)

References

(Depends on 1 open bug)

Details

Start browser.
Open mail, connect to a server that has a mailbox with enuf messages to generate
quota warning dialogs (or some other dialog).
When that dialog is up, go to the browser window and select Exit or Quit from
the File menu.

You will hang -- apparently the loop that we are in showing the dialog keeps
mail news from being notified of an app close. I was unable to click on the OK
button on the mailnews warning dialog, and had to kill mozilla process using an
xterm.
Product: MailNews → Core
Assignee: mscott → nobody
Severity: normal → critical
QA Contact: esther → backend
Summary: Can lock up mailnews/browser this test case → Can lock up browser if quota exceeded when dialog presented in mailnews
Product: Core → MailNews Core
If this problem still exists, isn't it a generic dialog problem and not quota-specific?
I think this is SeaMonkey specific, but bug 123440 may help the cause.
Component: Backend → MailNews: Backend
Depends on: 123440
Product: MailNews Core → SeaMonkey
QA Contact: backend → mailnews-backend
Depends on: 558014
No longer depends on: 123440
Hmm Wayne, did bug 123440 fix this specific problem?
(In reply to comment #3)
> Hmm Wayne, did bug 123440 fix this specific problem?

could be. But I'm not using SM lately. And Syd is not around
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
You need to log in before you can comment on or make changes to this bug.