Closed Bug 942283 Opened 6 years ago Closed 6 years ago

Provide a way to add RSS feeds to lists on about:home

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 977200

People

(Reporter: Margaret, Assigned: mcomella)

References

(Blocks 1 open bug)

Details

(Whiteboard: shovel-ready)

This will likely depend on the work from bug 862805 and bug 941318, but we should think about how we want to provide RSS integration with lists.
We should investigate implementing an "RSS provider" as an add-on, similarly to how a third-party service provider would be implemented.

Although the work to add new lists to about:home hasn't landed yet, we could start work on this by building an add-on that can subscribe to an RSS feed, then just displays the feed data in a simple HTML page. Then, once the lists API lands we can hook this data source up to that API.

I talked to mcomella about this earlier today, and he sounded interested in working on this, so I'm cc'ing him in case he wants to take this on :)
Whiteboard: shovel-ready
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
(In reply to :Margaret Leibovic from comment #1)
> we could
> start work on this by building an add-on that can subscribe to an RSS feed,
> then just displays the feed data in a simple HTML page.

I have an addon that can take a feed URL and dump the contents (poorly) into an HTML page [1]. Note there's no subscription model yet.

> Then, once the lists API lands we can hook this data source up to that API.

I will start looking into this.

[1]: https://github.com/mcomella/fennec_rss
(In reply to Michael Comella (:mcomella) from comment #2)
> (In reply to :Margaret Leibovic from comment #1)
> > we could
> > start work on this by building an add-on that can subscribe to an RSS feed,
> > then just displays the feed data in a simple HTML page.
> 
> I have an addon that can take a feed URL and dump the contents (poorly) into
> an HTML page [1]. Note there's no subscription model yet.

Sweet!

> > Then, once the lists API lands we can hook this data source up to that API.
> 
> I will start looking into this.

The data storage API will be developed in bug 942288.

The API for registering a panel to show this in already exists in Home.jsm, but we need to finish bug 959862 to specify what kind of views and datasets to show in the panels. I'm working on that now!
The list_integration branch of the addon [1] now uses the Home.jsm and HomeProvider.jsm to register my add-on and dump the CNN RSS feed into the DB.

[1]: https://github.com/mcomella/fennec_rss/tree/list_integration
Depends on: 969004
I'm duping this to bug 977200, since we decided we're going to solve this problem with an add-on, and we're working on that add-on there.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 977200
You need to log in before you can comment on or make changes to this bug.