The height of editor spell check dialog is too short so you can see only the top of the buttons at the bottom.

RESOLVED FIXED in seamonkey2.26

Status

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: dxmm, Assigned: philip.chee)

Tracking

SeaMonkey 2.22 Branch
seamonkey2.26
x86_64
Windows 7

SeaMonkey Tracking Flags

(seamonkey2.24 fixed, seamonkey2.25 fixed, seamonkey2.26 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 SeaMonkey/2.22 (Beta/Release)
Build ID: 20131023190953

Steps to reproduce:

Default Theme. Problem in SM on Win7 but not on Linux. Others have apparently seen this fault on WinXP systems.

When I mis-spell a word in a news post (and, probably in an e-mail as well), the Spell-Check sub-window displays but the "Send" button is only half drawn because its bottom half is below the sub-windows frame



Actual results:

I cannot drag the bottom edge of window down, nor is there a scroll-bar showing.

If I move the window, it is then fully drawn.


Expected results:

The bottom of the sub-window should always be below the last line of text/buttons

Comment 1

6 years ago
I experience this same problem in SM 2.22, Default theme, Windows XP.

Not sure when it began; sometime in the past month or two.

Some users say they can see this dialog full size if they move it in some way; for me, it always stays clipped.
(Assignee)

Updated

6 years ago
Summary: Drop-Down windows only being part drawn → The hight of editor spell check dialog is too short so you can see only the top of the buttons at the bottom.
(Assignee)

Comment 2

6 years ago
Possible fallout from:
Bug 856270 - Update nsEditorSpellCheck to use nsIContentPrefService2
See comm-central changeset 1a4332221534
(Part of bug 880595 - Fix the compose window spell check dialog.)

> +  window.sizeToContent();

Added this to the end of spellCheckStarted(). WAG since the spellchecker is now async we need to sizeToContent after the spellchecker has initialized.

> -<dialog buttons="cancel" title="&windowTitle.label;"
> +<dialog id="spellCheckDlg" buttons="cancel" title="&windowTitle.label;"
>      xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
>      persist="screenX screenY"

You can't persist anything if the element doesn't have an ID.
Assignee: nobody → philip.chee
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8337787 - Flags: review?(neil)
Posted image CheckSpelling.png
FTR, I had done some regression window hunt and identified the following:

Dialog bottom = OK button half: 07-17
Dialog bottom = OK button bottom: 07-16 - 07-05
Dialog bottom = OK button bottom + some space; no Language selected: 07-04

Glad to see that Ratty went right on to fixing. :-)
Summary: The hight of editor spell check dialog is too short so you can see only the top of the buttons at the bottom. → The height of editor spell check dialog is too short so you can see only the top of the buttons at the bottom.
Comment on attachment 8337787 [details] [diff] [review]
Patch v1.0 Proposed fix.

[Of course it's annoying that there's a brief glitch while we wait for the spellchecker to initialise so that we can fill the dialog...]
Attachment #8337787 - Flags: review?(neil) → review+
Philip, I guess this dropped off your radar? I think we should get this landed ASAP; ideally for 2.24 even.
(Assignee)

Comment 6

5 years ago
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #5)
> Philip, I guess this dropped off your radar? I think we should get this
> landed ASAP; ideally for 2.24 even.
I was waiting for the tree to turn green. I thought it was going to be temporary....
(Assignee)

Comment 7

5 years ago
Pushed comm-central changeset ef334467a41c
remote: https://hg.mozilla.org/comm-central/rev/ef334467a41c
Target Milestone: --- → seamonkey2.26
(Assignee)

Comment 8

5 years ago
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #5)
> I think we should get this landed ASAP; ideally for 2.24 even.
Please nominate for aurora and beta.
Comment on attachment 8337787 [details] [diff] [review]
Patch v1.0 Proposed fix.

[Approval Request Comment]
Regression caused by (bug #): Bug 856270
User impact if declined: Spell check dialog broken (not initialized)
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none
Attachment #8337787 - Flags: approval-comm-beta?
Attachment #8337787 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #8337787 - Flags: approval-comm-beta?
Attachment #8337787 - Flags: approval-comm-beta+
Attachment #8337787 - Flags: approval-comm-aurora?
Attachment #8337787 - Flags: approval-comm-aurora+
Philip, why did you not land this on the branches (or delegate, in case you lacked the time to do it yourself)? Now, unless we're fast and releng re-tags, this will miss 2.24. :-(
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

5 years ago
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #10)
> Philip, why did you not land this on the branches (or delegate, in case you
> lacked the time to do it yourself)? Now, unless we're fast and releng
> re-tags, this will miss 2.24. :-(
Very sorry. Will miss 2.24b1 but will make it for 2.24 final.

Pushed:
remote:   https://hg.mozilla.org/releases/comm-aurora/rev/b03561ae7689
remote:   https://hg.mozilla.org/releases/comm-beta/rev/874f4107c0fd
You need to log in before you can comment on or make changes to this bug.