"media playback tests in utility tray should play/pause from now playing widget after closing and reopening music app" in apps/system/test/marionette/media_playback_test.js

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rik, Assigned: kgrandon)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1) media playback tests in utility tray should play/pause from now playing widget after closing and reopening music app:
     
  ElementNotVisible: (11) Element is not visible
  Remote Stack:
  <none>
      at Error.MarionetteError (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)
      at Object.Client._handleCallback (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/client.js:474:19)
      at /Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/client.js:508:21
      at TcpSync.send (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:94:10)
      at Object.send (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/client.js:455:36)
      at Object.Client._sendCommand (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/client.js:501:19)
      at Object.Element._sendCommand (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/element.js:49:21)
      at Object.click (/Users/rik24d/code/gaia/node_modules/marionette-client/lib/marionette/element.js:172:19)
      at click (/Users/rik24d/code/gaia/apps/system/test/marionette/lib/media_playback.js:12:11)
      at Object.MediaPlaybackContainer.playPause (/Users/rik24d/code/gaia/apps/system/test/marionette/lib/media_playback.js:101:5)
      at /Users/rik24d/code/gaia/apps/system/test/marionette/media_playback_test.js:153:21
      at Object.MediaPlayback.inUtilityTray (/Users/rik24d/code/gaia/apps/system/test/marionette/lib/media_playback.js:158:5)
      at Context.<anonymous> (/Users/rik24d/code/gaia/apps/system/test/marionette/media_playback_test.js:151:35)
      at Test.Runnable.run (/Users/rik24d/code/gaia/node_modules/mocha/lib/runnable.js:211:32)
      at Runner.runTest (/Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:355:10)
      at /Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:401:12
      at next (/Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:281:14)
      at /Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:290:7
      at next (/Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:234:23)
      at Object._onImmediate (/Users/rik24d/code/gaia/node_modules/mocha/lib/runner.js:258:5)
      at processImmediate [as _immediateCallback] (timers.js:330:15)
(Assignee)

Comment 1

5 years ago
Possibly caused by bug: 936201?

I'm seeing this error a lot right now, and backing the patch out caused travis 10 runs of green: https://travis-ci.org/mozilla-b2g/gaia/builds/14478379
(Assignee)

Comment 2

5 years ago
Created attachment 8337602 [details] [review]
Github revert

Rik - I'm going to sleep now, but I am fairly confident that this is the bug that's causing the intermittent. Since you're in the Paris office maybe you can look at it with Sam. Otherwise I'll look again when I'm up. Thanks!

If you feel like landing this - go for it.
Attachment #8337602 - Flags: review?(anthony)
(Reporter)

Comment 3

5 years ago
Thanks Kevin for testing this. When I back out this patch, I'm still seeing the patch failing locally on my Mac. But since your Travis run is green, we'll take it to get a green Travis.

FYI, I'm in Taipei this week.
(Reporter)

Updated

5 years ago
Attachment #8337602 - Flags: review?(anthony) → review+
(Reporter)

Updated

5 years ago
Blocks: 936201
(Reporter)

Comment 4

5 years ago
It was merged in https://github.com/mozilla-b2g/gaia/commit/13aa630971cbe92beebdea7a05082ef712180624, closing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 946615
No longer blocks: 946615

Updated

5 years ago
Assignee: nobody → kgrandon
You need to log in before you can comment on or make changes to this bug.