Promo panel to advertise customization in about:home

RESOLVED INVALID

Status

()

Firefox for Android
Awesomescreen
P3
normal
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: ibarlow, Assigned: Margaret)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This bug is to add a promo panel to the far right of the home screen, to encourage users to add lists. 

Designs will be posted shortly.
(Reporter)

Updated

5 years ago
Depends on: 942881
(Reporter)

Comment 1

5 years ago
Created attachment 8345280 [details]
Mockup of promo page

This panel always sits at the far right of a user's home screen pages. Tapping the "Try it out" button launches the list chooser menu.

Text:

Tab title: 
NEW

Title: 
Personalize your Home page

Body:
You can make Firefox even more useful by adding feeds and subscribing to online services!

Button:
Try it out
(Reporter)

Updated

5 years ago
Summary: Lists Promo Panel → Lists Promo Page
(Reporter)

Updated

5 years ago
Duplicate of this bug: 942881
(Assignee)

Comment 3

5 years ago
Let's fix bug 942878 first, since that will add the dialog that we'll want to open from this promo panel.
Depends on: 942878
Summary: Lists Promo Page → Promo panel to advertise customization in about:home
(Assignee)

Updated

5 years ago
No longer depends on: 942881
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Updated

4 years ago
Priority: P1 → P2
(Assignee)

Comment 4

4 years ago
I wonder how we should implement this. It would be nice to implement this in JS using the regular Home.panels API, but it is different enough that we would need to augment the API to make this work, and it's probably not worth doing that only for this one case. We've talked about wanting an introductory empty panel for the home feeds add-on, so maybe this is something to consider.

However, if this is something that we always want to include, it might make more sense to add it to the set of built-in default panels.

Question: What's the lifecycle of this panel? Do we want it to stay in the user's home configuration for all time, or make it disappear after they install a new panel? Also, do we want it to appear in settings with the rest of the built-in panels, so that the user can hide it there?
Assignee: nobody → margaret.leibovic
Flags: needinfo?(ibarlow)
My initial take on this would be:
- Promo panel should just be one of the default built-in panels.
- As such, you can hide/show it at any time. No special life-cycle for it. Users should be able to explicitly hide it if they don't find it useful.
- Make it more useful, show recommended content directly in the panel instead of just being a shortcut to something else i.e. show recommended panels with a quick way to add them (just like the new picker?). Make it look cool too i.e. not just a flat list of text-only rows.

The original intent of the promo panel (based on the screenshot alone) should probably go into the first-run UX work i.e. make it obvious to new users how to add custom stuff to their homepage.
(Reporter)

Comment 6

4 years ago
(In reply to Lucas Rocha (:lucasr) from comment #5)
> My initial take on this would be:
> - Promo panel should just be one of the default built-in panels.
> - As such, you can hide/show it at any time. No special life-cycle for it.
> Users should be able to explicitly hide it if they don't find it useful.

That's pretty much what I was thinking as well. 

> - Make it more useful, show recommended content directly in the panel
> instead of just being a shortcut to something else i.e. show recommended
> panels with a quick way to add them (just like the new picker?). Make it
> look cool too i.e. not just a flat list of text-only rows.

Yes, we definitely want to make it interesting looking than a plain list, and will probably want to use it to call out new or special panels. 

> The original intent of the promo panel (based on the screenshot alone) should probably
> go into the first-run UX work i.e. make it obvious to new users how to add custom 
> stuff to their homepage.

Also this, yes. Still to be determined whether it's part of an 'intial setup' experience, or part of a 'feature tour' experience.
Flags: needinfo?(ibarlow)
(Assignee)

Updated

4 years ago
Priority: P2 → P3
(Assignee)

Comment 7

4 years ago
Given our recent decision to remove the "Add panel" item from settings, how do we feel about this bug? If we implement this promo panel, where should the "Try it out" button link to? A collection on a.m.o.? I feel like we should hold off on implementing this bug, since it may seem odd to have this whole big piece of native UI just link to a webpage. But I could also just be a lazy engineer :)
Flags: needinfo?(ibarlow)
(Reporter)

Comment 8

4 years ago
Seems like we're going back to the drawing board a bit on all this. I agree, let's park this bug for the time being.
Flags: needinfo?(ibarlow)
(Assignee)

Comment 9

4 years ago
We're getting rid of the current panel picker, so we would nee do rethink the flow here if we were to go with this. I'm closing this bug out, and we can file new ones when we have a new plan.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.