Closed Bug 943128 Opened 8 years ago Closed 8 years ago

[B2G][Bluetooth][Device Name]On initial launch, device name in Bluetooth is blank.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g18 unaffected, b2g-v1.2 affected)

RESOLVED DUPLICATE of bug 932914
Tracking Status
b2g18 --- unaffected
b2g-v1.2 --- affected

People

(Reporter: pbylenga, Unassigned)

Details

Attachments

(3 files, 1 obsolete file)

Description:
On initial launch or after resetting phone the device name is blank in Bluetooth instead of default device name.

Pre-requisites:
Reset phone to factory defaults via Settings App.

Repro Steps:
1) Updated Buri to Build ID: 20131125004001
2) Launch Settings App and navigate to Bluetooth menu
3) Enable Bluetooth and observe Device Name

Actual:
Device Name is blank.

Expected:
Device Name is set to the default value.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131125004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/368ea26d2136
Gaia: c2dea53b36bb9d4331a94976344515f60dc5a3d4
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2_20131115

Notes:
Repro frequency: 5/5, 100%
See attached: &screenshot & logcat
Attached image DeviceNameMissing.png
Attached image DeviceNameMissing_VisibilityON.png (obsolete) —
This issue does not reproduce on 1.1.

Environmental Variables:
Device: Leo 1.1 mozRIL
BuildID: 20131122041201
Gaia: b7610870ec71495685557744bfbcbce357032251
Gecko: c699a8e7bde9
Version: 18.0
Firmware Version: V10d
I do not follow this bug at all. Can you provide better clarification of the bug here?
Flags: needinfo?(pbylenga)
Edited the VisibilityON screenshot to show a comparison of what is expected vs the actual observation.  You can get the device name to appear after pairing and turning Bluetooth ON/OFF.
Attachment #8338121 - Attachment is obsolete: true
Flags: needinfo?(pbylenga)
Walter - Can you figure out how bad this is in terms of impact? This is bluetooth related. I don't fully understand what the text under visible to all is trying to solve.
Flags: needinfo?(wachen)
Flags: needinfo?(wachen)
This is fixed in master branch. I don't see a big impact on this. Eric Chou will explain more to you later.
The symptom is quite similar to bug 932914. However, it should be fixed in the build of 20131122041201. Let me try again and update soon.
I found that the patch for bug 932914 wasn't successfully pushed to branch v1.2, and that's why we can still reproduce this issue on v1.2.

Let's mark this as a dup of bug 932914 and I'm going to re-open bug 932914 for tracking.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932914
You need to log in before you can comment on or make changes to this bug.