Status

()

defect
RESOLVED DUPLICATE of bug 861266
6 years ago
6 years ago

People

(Reporter: fb+mozdev, Unassigned)

Tracking

({relnote})

26 Branch
Firefox 26
Points:
---

Firefox Tracking Flags

(relnote-firefox -, relnote-b2g ?)

Details

Reporter

Description

6 years ago
The release notes don't mention TLS on-by-default yet (and I did not want to resurrect the old bugs). 

Fx 26, Bug 733647 (and B2G 1.2, see Bug 733647 Comment 58):
"Enabled TLS 1.1 by default."

Fx 27, Bug 861266 (thus B2G 1.3):
"Enabled TLS 1.2 by default."


The extended release notes / press release should (to avoid confusion in the press) point out that Firefox did support TLS 1.1 (pref-able since Fx 23, accoding to Bug 733642) and (iirc) TLS 1.2 (don't know which) since a few versions, but has only been enabled in the above mentioned versions. The Fx 26 press release could also mention that TLS 1.2 is coming in the next, Fx 27 version.
This is not appropriate to be tracked by a tracking flag or a blocking flag.
blocking-b2g: koi? → ---
relnote-firefox: ? → ---
Product: Firefox → Firefox OS
Target Milestone: Firefox 26 → ---
Version: 26 Branch → unspecified
Reporter

Comment 2

6 years ago
This is mostly a Firefox thing, not Firefox OS (though it applies to it as well but inherits). 
This is important for PR.
relnote-firefox: --- → ?
Product: Firefox OS → Firefox
Target Milestone: --- → Firefox 26
Version: unspecified → 26 Branch
relnote? is enough for it to get brought up for discussion on final release notes.
Reporter

Comment 4

6 years ago
Bug 944465 disabled TLS 1.1 for Fifefox 26, so no need to relnote that.
Depends on: 944465
Reporter

Comment 5

6 years ago
Sorry for bugspam :-/
No longer depends on: 944465
See Also: → 944465
Florian, as you can see by what happened with the enabling/disabling of TLS 1.1, the relnote keyword and relnote-firefox? flags are a better way of tracking the need to add a release note. I will add those to bug 861266.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861266
You need to log in before you can comment on or make changes to this bug.