Closed Bug 943365 Opened 7 years ago Closed 6 years ago

Offer a simpler solution to disable lightweight themes when window is not maximized

Categories

(Firefox :: Toolbars and Customization, enhancement)

x86_64
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ronan, Unassigned)

Details

(Whiteboard: [Australis:P-])

Hi.

I use GNOME3 with the Mutter window manager, which doesn't allow title bar painting, so applying for example the "Black" lightweight theme results in something not pretty at all [1]. But when maximizing the window and hiding the title bar with Maximus [2], it actually looks great [3]. So I built a set of userChrome.css rules in order to use my lightweight theme _only when maximized_ [4].

→ Does my (ugly, needs-maintenance to adapt to browser.css changes) userChrome.css [4] sound like something that might be fixed in another way? Do you have something else simpler to recommend? Any plans to make this "feature" easier for GNOME3 users in the scope of Australis?

Note: I know my use case is extremely specific! By all means, do NOTABUG/WONTFIX it, I've been living with this kind of userChrome.css for years and am happy with it. I was just updating it for Australis, and thought that since you are working on that kind of stuff for Australis, now would be a good opportunity to ask for a better solution.

Thanks!

[1] https://dl.dropboxusercontent.com/u/368761/bugreport/firefox-australis-userchromecss-lightthemeonlywhennotmaximized/1-lightweight-theme-and-unpainted-titlebar.png
[2] https://extensions.gnome.org/extension/354/maximus/
[3] https://dl.dropboxusercontent.com/u/368761/bugreport/firefox-australis-userchromecss-lightthemeonlywhennotmaximized/2-fullscreen-lightweight-theme-and-hidden-titlebar.png
[4] https://dl.dropboxusercontent.com/u/368761/bugreport/firefox-australis-userchromecss-lightthemeonlywhennotmaximized/userChrome-disable-lightweight-theme-when-not-maximized.css
Whiteboard: [Australis:P-]
An add-on could disable lightweight themes depending on the size mode with JavaScript, no CSS needed.
No longer blocks: australis-tabs, australis-merge
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.