Closed Bug 943375 Opened 7 years ago Closed 7 years ago

Using Australis customize results in tab bar collides with the buttons on the upper left hand

Categories

(Firefox :: Untriaged, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 941831

People

(Reporter: yeukhon, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P-])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131126030201

Steps to reproduce:

Click on hamburger button, click on customize and save without doing any changes.


Actual results:

See screenshot - upper left hand collides with the tab bar and if you look at it more closely there might be some solid gradient in the background (but it somehow goes away if you open a few more tabs)
Quick comment - restart firefox and everything looks okay again.
Can you reproduce this on a fresh profile?
Flags: needinfo?(yeukhon)
(In reply to :Gijs Kruitbosch from comment #2)
> Can you reproduce this on a fresh profile?

Thanks. I just created a new profile and used an existing profile (not the one that caused the issue) and I confirm I cannot reproduce. 
What should I provide to you?
Flags: needinfo?(yeukhon)
(In reply to yeukhon from comment #3)
> (In reply to :Gijs Kruitbosch from comment #2)
> > Can you reproduce this on a fresh profile?
> 
> Thanks. I just created a new profile and used an existing profile (not the
> one that caused the issue) and I confirm I cannot reproduce. 
> What should I provide to you?

It'd probably be helpful if you could provide a list of add-ons and/or checked if you can narrow down which of the add-ons (if any) is causing the issue, by enabling/disabling some of them and checking if you can reproduce (on the profile where you *can* reproduce). Thank you!
Flags: needinfo?(yeukhon)
(In reply to :Gijs Kruitbosch from comment #4)
> (In reply to yeukhon from comment #3)
> > (In reply to :Gijs Kruitbosch from comment #2)
> > > Can you reproduce this on a fresh profile?
> > 
> > Thanks. I just created a new profile and used an existing profile (not the
> > one that caused the issue) and I confirm I cannot reproduce. 
> > What should I provide to you?
> 
> It'd probably be helpful if you could provide a list of add-ons and/or
> checked if you can narrow down which of the add-ons (if any) is causing the
> issue, by enabling/disabling some of them and checking if you can reproduce
> (on the profile where you *can* reproduce). Thank you!

I have no addon and use only the default theme. I stated using a new profile and I just realized what was causing this bug.

I have enabled web page title to be shown in the windows title bar. Please refer to https://bugzilla.mozilla.org/show_bug.cgi?id=940093#c1

If you enable this (which sets the boolean to false), then after you click on hamberger button, then customize then exit the customize view, you will see

1. title is gone
2. control buttons collide with your tabs
3. there are solid gradient in the background

If you check about:config, and look for browser.tabs.drawInTitlebar, the value is still false (which is the value to enable title to be shown in windows titlebar).
If you then switch to true (or restart firefox), control buttons no longer collide with tabs.

This will block https://bugzilla.mozilla.org/show_bug.cgi?id=940093 from landing in my honest opinion and is probably related to https://bugzilla.mozilla.org/show_bug.cgi?id=941559 as well.
Flags: needinfo?(yeukhon)
Blocks: 940093
Marking this as P- due to the need to flip a pref in about:config to see this bug.
Whiteboard: [Australis:P-]
This also happens when disconnecting and reconnecting to an external monitor.  I'm pretty sure that I had filed that bug before but I can't find it right now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dupe of bug 941831, AFAICS.

(In reply to Jared Wein [:jaws] from comment #6)
> Marking this as P- due to the need to flip a pref in about:config to see
> this bug.

Bug 940093 is going to expose that pref in the UI, so this really needs to be fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 941831
You need to log in before you can comment on or make changes to this bug.