mozregression produced a bad changeset URL

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8338705 [details]
log

I range mozregression but I didn't get a good URL (see log):
http://hg.mozilla.org/mozilla-central//pushloghtml?fromchange=1bf867ff4215&tochange=78cd3e278127

Ideally we should improve this message to something with as much information we can easily gather and format it such that it can be posted directly in a bug. See https://bugzilla.mozilla.org/show_bug.cgi?id=787892#c1 for a perfect example.
(Reporter)

Updated

5 years ago
Flags: needinfo?(wlachance)
Summary: mozregression produced a bar changeset URL → mozregression produced a bad changeset URL
What command line did you provide to mozregression to get this result?
Flags: needinfo?(wlachance) → needinfo?(bgirard)
Nevermind, just realized that info was in the log.
Flags: needinfo?(wlachance)
The problem here seems to be that you're using inbound builds to narrow down the range, but still spitting out a mozilla-central-based URL for the regression range. If you swap m-i for m-c in that URL you get a nice result:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1bf867ff4215&tochange=78cd3e278127
There were two problems:

1. What Ted mentioned
2. We were using commit timestamps to get the inbound range, rather than an actual pushlog.

With these issues fixed, we're now actually getting useful results.

https://github.com/mozilla/mozregression/commit/87db475cfc04d3c7f1c52f87ecff0f91b74dd17e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(wlachance)
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
clearing needinfo per comment 2.
Flags: needinfo?(bgirard)
Component: General → mozregression
You need to log in before you can comment on or make changes to this bug.