Closed Bug 943560 Opened 6 years ago Closed 6 years ago

paused song no longer plays

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dietrich, Unassigned)

References

Details

(Keywords: dogfood, regression)

Seen on master + m-c build from yesterday on Nexus 4. Can reproduce easily.

STR:

1. play a song in music app
2. hit pause
3. press power button to lock screen
4. press power button to power on screen
5. unlock phone
6. hit play

Expected: song continues playing

Actual: the button turns into the pause icon, but the counter doesn't change and there's no audio.
blocking-b2g: --- → 1.3?
Keywords: dogfood
QA Contact: sparsons
I am unable to reproduce this issue on Buri and Helix 1.3 Build ID: 20131127040203

Gaia   d4b9a3d271f0451b4d903a03c2b931b8cc092041
SourceStamp 6ecf0c4dfcbe
BuildID 20131127040203
Version 28.0a1

also, I am unable to reproduce on Buri 1.2 Build ID: 20131127004001

Gaia   92cd11ea023dd6598d82d859ae3c945ff6589ce6
SourceStamp 14e91ab12441
BuildID 20131127004001
Version 26.0

Possibly a Nexus 4 specific issue?
Are you sure this isn't bug 937060, which affects Nexus 4?
For nexus4, Bug 919590 is already present.
Reproduced still on build from today (12/4) on Nexus 4.

Revised STR, this actually requires no sleep/unlock:

1. Play a song
2. hit pause
3. hit play

Expected: song plays

Actual: song plays for 1 second then stops playing. Countdown timer also stops, and button is showing pause symbol.

Logcat: a bunch of these:

E/OMXCodec( 3410): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
Summary: paused song no longer plays after screen lock->unlock → paused song no longer plays
workarounds:

* go to next track, then go back
* go to album view, then select the track again
Yeah, this is definitely a dupe of bug 937060 or maybe bug 919590 then.
Marking this a dependent on 919590. Lets re-test this once that bug is fixed.
blocking-b2g: 1.3? → ---
Depends on: 919590
In file OmxDecoder.cpp :-
nsresult OmxDecoder::Pause()
{
  if (!mIsPauseDisabled) {
    return NS_ERROR_NOT_IMPLEMENTED;
  }
  
  if (mVideoPaused || mAudioPaused) {
    return NS_OK;
  }

  if (mVideoSource.get() && mVideoSource->pause() == OK) {
    mVideoPaused = true;
  }

  if (mAudioSource.get() && mAudioSource->pause() == OK) {
    mAudioPaused = true;
  }
  return NS_OK;
}

Patch submitted for bug 919590 on comment 15 and 16 with above changes fixes the issue. In the above code I have just changed the return type of Pause and returned NC_OK. I have checked this fix on emulator. It works fine.
could we please re-verify if this is fixed in nexus4?
This issue is not reproducible on Nexus-4

OS Version : 2.0.0.0 Pre-release
Hardware : Mako
Platform Version : 32.0a1
Git Commit Info : 2014-05-05 16:59:23
Marking it WORKSFORME based on last comment. If it is still an issue, reopen it
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.