Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 77067
17 years ago
17 years ago

People

(Reporter: Kurt Swanson, Assigned: dbaron)

Tracking

Trunk
mozilla0.9.4
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802
BuildID:    2001080221

Links in the bookmarks.html file overlap each other.  Specifically, the
rectangles which represent the clickable area for a link extend too far on the
top edge, overlapping possible links above.

I will attach a gif showing the situation.

I'm using times new roman truetype, 16 pt, 96dpi.

This symptom seems to be endemic to a larger problem about font heights, notably
visible in form fields.

Reproducible: Always
Steps to Reproduce:
1.View own bookmarks file
2.Click on second link
3.Immediately hit ESC.
4.Dashed box shows clickable area extending at least 3 pixels into previous link.

Actual Results:  overlapping links

Expected Results:  non-overlapping links
(Reporter)

Comment 1

17 years ago
Created attachment 45111 [details]
screenshot showing link overlap
This is probably a duplicate of "The way we get font metrics from X11 is bad",
but marking dependency for now....

assigning to dbaron
Assignee: karnaze → dbaron
Depends on: 91794
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 3

17 years ago
Fix for bug 91794 checked in 2001-08-23 06:44 PDT.


*** This bug has been marked as a duplicate of 77067 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.