Convert to Promise.jsm in the app manager

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
5 years ago
4 months ago

People

(Reporter: bbenvie, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Blocks: 881050
(Reporter)

Comment 1

5 years ago
Created attachment 8338950 [details] [diff] [review]
promise-appmanager.patch

Switches app manger to use Promise.jsm. https://tbpl.mozilla.org/?tree=Try&rev=e72f99504fff
Assignee: nobody → bbenvie
Status: NEW → ASSIGNED
(Reporter)

Comment 2

5 years ago
Created attachment 8339611 [details] [diff] [review]
promise-appmanager.patch

I have a feeling this won't fix the failure, but let's try. https://tbpl.mozilla.org/?tree=Try&rev=3a6725252b5e
Attachment #8338950 - Attachment is obsolete: true
(Reporter)

Comment 3

5 years ago
Clarification: this is a timing issue I cannot reproduce locally. =(
(Reporter)

Updated

5 years ago
Blocks: 931679

Comment 4

5 years ago
Still failing:

https://tbpl.mozilla.org/?tree=Try&rev=fa3da02191dd

Comment 5

5 years ago
Created attachment 8394135 [details] [diff] [review]
Updated patch

Still failing after this obvious fix.

https://tbpl.mozilla.org/?tree=Try&rev=a2a32ac71943
Attachment #8339611 - Attachment is obsolete: true

Comment 6

5 years ago
Created attachment 8394913 [details] [diff] [review]
Race condition

There seems to be a race condition with the selectProject function. It seems that the first project added is selected automatically, but we click the first element in the list again during the selection process, and this triggers the race condition.

This added timeout makes the race condition occur locally.

This might be related to the intermittent failure in bug 950613.

Ideas on how to fix this?
Attachment #8394135 - Attachment is obsolete: true

Updated

5 years ago
Blocks: 950613

Comment 7

5 years ago
Created attachment 8397094 [details] [diff] [review]
Simplified test

Simplified the test, but still fails remotely and not when run individually.
Attachment #8394913 - Attachment is obsolete: true
Assignee: bbenvie → nobody
Status: ASSIGNED → NEW
App Manager is slated to be removed, so it may not make sense to work on this.
Depends on: 1007061
App manager removed!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.