Closed Bug 943701 Opened 6 years ago Closed 6 years ago

[Settings] the “Do Not Track” panel is broken

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: kaze, Assigned: eeejay)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

See attached screenshot:
 • the text is unreadable, even in English — we should have some line wrapping here;
 • the higlight area does not cover the whole list item.
Another regression of bug 914892.
Blocks: 914892
Keywords: regression
blocking-b2g: --- → 1.3?
Eitan, can you check this one too please?
Assignee: nobody → eitan
Flags: needinfo?(eitan)
The “description” class has been affected by bug 914892, please make sure to check all paragraphs in li.description elements.
Attachment #8339460 - Flags: review?(kaze)
Flags: needinfo?(eitan)
Much better, but the highlight does not cover the whole list item. Do you think you can fix that, too?
Comment on attachment 8339460 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14137

Please r? me again after having addressed my previous comment.
Attachment #8339460 - Flags: review?(kaze)
Attachment #8339457 - Attachment is obsolete: true
Comment on attachment 8339460 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14137

After playing a lot more with the paddings/margins, I gave up. This fix, which I am not proud of, removes the :active styling from .description labels.

I also have a suspicion that no highlight here is perhaps a UX decision?
Attachment #8339460 - Flags: review?(kaze)
Duplicate of this bug: 944404
Duplicate of this bug: 941955
Triage: severe UI breakage.
blocking-b2g: 1.3? → 1.3+
Duplicate of this bug: 947434
eeejay, please de-assign yourself If you no longer working on this bug.

If you do, please set a target milestone. Thanks.
Flags: needinfo?(eitan)
Comment on attachment 8339460 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14137

I confess I’m not completely pleased by this patch, for the reasons Eitan mentioned (= all items that have multi-line descriptions will lose their :active styling), but I couldn’t come up with a better solution yet — and this patch sure is a necessary improvement.

Given the timeframe, I’d suggest to land this patch (hence my R+) and open another bug to fix the :active styling for the whole Settings app. Arthur, Evelyn, is that OK with you?
Attachment #8339460 - Flags: review?(kaze) → review+
Flags: needinfo?(eitan) → needinfo?(arthur.chen)
Duplicate of this bug: 946113
The text was placed in a <p> before and has been move to a <span> inside a <label>. Hence it is applied with the following styles that I think is critical to this issue. 

ul li > label > span {
  line-height: 6rem;
}

ul li > label > * {
  overflow: hidden;
  text-overflow: ellipsis;
  white-space: nowrap;
}

A proper fix would be adding a new semantic in which the above styles are overridden.
Flags: needinfo?(arthur.chen)
Attached file patch for Gaia/master
I try to unify almost all list items who looks like `descriptions` because we have a lot of variation of it
Attachment #8349013 - Flags: review?(kaze)
Attachment #8339460 - Flags: review+
Comment on attachment 8349013 [details] [review]
patch for Gaia/master

Wow, nice work! Thanks for your quick help Pavel.

Eitan, does this look OK to you as well?
Attachment #8349013 - Flags: review?(kaze)
Attachment #8349013 - Flags: review+
Attachment #8349013 - Flags: feedback?(eitan)
Do you think it solves bug 942618 too?
(In reply to Théo Chevalier [:tchevalier] from comment #19)
> Do you think it solves bug 942618 too?

Just tested that. And not quite. The checkbox is on the wrong side. But ultimately I think the fix should go in pavel's patch.
Duplicate of this bug: 942618
Blocks: 942618
Attachment #8349013 - Flags: feedback?(eitan) → feedback+
Thanks guys :)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/0e153b7211eb525d448470fdcabbd0f22663f9a0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You rock! Thanks for this really nice cleanup.
Whiteboard: dogfood1.3
Whiteboard: dogfood1.3
Uplifted 0e153b7211eb525d448470fdcabbd0f22663f9a0 to:
v1.3: 1f60e3f6a0f7a99eba75989eaabb1b1249c67766
You need to log in before you can comment on or make changes to this bug.