Closed Bug 943809 Opened 6 years ago Closed 4 years ago

[bluedroid] HID prototype

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1223729

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

References

Details

Attachments

(6 files, 9 obsolete files)

1.00 KB, patch
Details | Diff | Splinter Review
1.79 KB, patch
Details | Diff | Splinter Review
5.06 KB, patch
arthurcc
: review+
Details | Diff | Splinter Review
469 bytes, patch
Details | Diff | Splinter Review
18.59 KB, patch
Details | Diff | Splinter Review
11.32 KB, patch
Details | Diff | Splinter Review
[bluedroid] HID prototype
Comment on attachment 8339889 [details] [diff] [review]
Bug943809-Part2: BluetoothHidManager for bluedroid

During integration with Setting, I found I missed event notification part.
Attachment #8339889 - Attachment is obsolete: true
Attachment #8339889 - Flags: review?(echou)
Attachment #8339887 - Attachment is obsolete: true
Attachment #8339887 - Flags: review?(echou)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Attachment #8340911 - Attachment description: Bug943809-Part1: Relocate files → Bug943809 - Part1: Relocate files
Attachment #8340912 - Attachment description: Bug943809-Part2: BluetoothHidManager for bluedroid → Bug943809 - Part2: BluetoothHidManager for bluedroid
Attachment #8340912 - Attachment description: Bug943809 - Part2: BluetoothHidManager for bluedroid → Bug 943809 - Part2: BluetoothHidManager for bluedroid
Attachment #8340911 - Attachment description: Bug943809 - Part1: Relocate files → Bug 943809 - Part1: Relocate files
Attached patch hid-gaia.patch (obsolete) — Splinter Review
Attachment #8340944 - Flags: feedback?(arthur.chen)
Assignee: nobody → shuang
Comment on attachment 8340944 [details] [diff] [review]
hid-gaia.patch

Shawn, thanks for the first gaia patch! :)

Please check my comment. And we also need to do some modifications on system/js/bluetooth.js.
Attachment #8340944 - Flags: feedback?(arthur.chen)
Attached patch hid-gaia-v2.patch (obsolete) — Splinter Review
Attachment #8340997 - Flags: feedback?(arthur.chen)
Attachment #8340911 - Attachment is obsolete: true
Attachment #8340911 - Flags: review?(echou)
Attachment #8340912 - Attachment is obsolete: true
Attachment #8340912 - Flags: review?(echou)
Comment on attachment 8340997 [details] [diff] [review]
hid-gaia-v2.patch

Review of attachment 8340997 [details] [diff] [review]:
-----------------------------------------------------------------

::: apps/system/js/bluetooth.js
@@ +10,4 @@
>        OPP: 'opp',   // Object Push Profile
>        A2DP: 'a2dp', // A2DP status
>        SCO: 'sco'    // Synchronous Connection-Oriented
> +      HID: 'hid'    // Synchronous Connection-Oriented

Please add the full name of "HID".

@@ +181,4 @@
>        self.updateConnected();
>      };
>  
> +    adapter.onhfpstatuschanged = function bt_hidStatusChanged(evt) {

Should be "onhidstatuschanged".
Attachment #8340997 - Flags: feedback?(arthur.chen)
Comment on attachment 8341525 [details] [diff] [review]
hid-gaia-v3.patch

Review of attachment 8341525 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thank you for the effort!
Attachment #8341525 - Flags: review?(arthur.chen) → review+
Comment on attachment 8341005 [details] [diff] [review]
Bug 943809 - Part1: Reallocate Hid files

Review of attachment 8341005 [details] [diff] [review]:
-----------------------------------------------------------------

Please remember to touch CLOBBER in order to trigger a clean build on tinderbox.
Attachment #8341005 - Flags: review?(echou) → review+
(In reply to Eric Chou [:ericchou] [:echou] (OOO 12/12 ~ 12/15) from comment #17)
> Comment on attachment 8341005 [details] [diff] [review]
> Bug 943809 - Part1: Reallocate Hid files
> 
> Review of attachment 8341005 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Please remember to touch CLOBBER in order to trigger a clean build on
> tinderbox.

Oh, I saw the 5th patch. Please forget what I just said in comment 17. :)
Attachment #8341526 - Flags: review?(echou) → review+
Comment on attachment 8341005 [details] [diff] [review]
Bug 943809 - Part1: Reallocate Hid files

We shall use 'hg mv' instead of deleting files.
Attachment #8341005 - Attachment is obsolete: true
Attachment #8341005 - Flags: review+
Attachment #8341006 - Attachment is obsolete: true
Attachment #8341006 - Flags: review?(echou)
Attachment #8348621 - Attachment is obsolete: true
Attachment #8348621 - Flags: review?(echou)
I've tried this patch on Nexus-4 with Apple Wireless keyboard and Logitech keyboard, which is based on bluedroid stack.
If you have problem with reconnect, see also bug 953019. Some HID keyboards don't support connection initiated from phone.
Assignee: shuang → joliu
Pass HID feature to Jocelyn :)
No longer blocks: 1017944
See Also: → 1017944
Assignee: joliu → shuang
We're going to have major refactoring on Bluetooth module, especially removing BT HAL dependent data type. So, after that was done, we will work on rebase patches.
Because we changed the way to access bluedroid through bluetoothd. These patch need to be re-written.
Hey cyu,
If you are interested in this bug, here you go!
Flags: needinfo?(cyu)
Blocks: TV_FxOS2.5
No longer blocks: TV_FxOS2.5
Blocks: 980768
See Also: → 1189253
Since we moved to Bluetooth APIv2, The gaia patch need to be re-written as well
Remove NI flag since this is currently not on my plate.
Flags: needinfo?(cyu)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223729
Bug 1223729 has covered HID prototype.
You need to log in before you can comment on or make changes to this bug.