Closed Bug 943859 Opened 9 years ago Closed 9 years ago

TART should run without forcing OMTC off

Categories

(Testing :: Talos, defect)

x86_64
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: avih, Assigned: avih)

References

Details

Attachments

(1 file)

Frame intervals recording has been broken with OMTC (bug 920123, bug 943041) and as a result we were forced to run TART with OMTC off.

As of bug 924403, performance without OMTC will drop sharply on OGL platforms.

- For builds up to roughly yesterday, talos should force OMTC for TART.
- For builds from tomorrow or so, talos should leave the OMTC pref at default, which would be on for OS X.

Bottom line is to stop forcing OMTC off for tart from now on.
Attachment #8339276 - Flags: review?(jmaher)
Comment on attachment 8339276 [details] [diff] [review]
Talos should now use default OMTC config for TART instead of forcing it off. r=jmaher

Review of attachment 8339276 [details] [diff] [review]:
-----------------------------------------------------------------

great!  if we were to land this today, would there be any issues?
Attachment #8339276 - Flags: review?(jmaher) → review+
(In reply to Joel Maher (:jmaher) from comment #1)
> great!  if we were to land this today, would there be any issues?

Yes, there would, until the dependency bugs are resolved. But we already have issues with regression since bug 924403 landed.

This is to be expected, and TART would be broken for a day or two.
by broken do you mean failing to run, or misreporting data?  we could wait and deploy this when a fix to osx is ready.
(In reply to Joel Maher (:jmaher) from comment #4)
> by broken do you mean failing to run, or misreporting data?  we could wait
> and deploy this when a fix to osx is ready.

Producing (different kind of) meaningless results (than it already does now since bug 924403 landed).
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
This bug was resolved-fixed 2 months ago, and from today it also depends on bug 965731 (update talos.zip).

Does this mean that the talos change in this bug still didn't propagate to production, 2 months after it landed on talos?
Flags: needinfo?(jmaher)
avi: I looked at all the bugs in commit messages in http://hg.mozilla.org/build/talos since the last revision in talos.json (82b7680f9eaf).  I presume your commit message was incorrect?
Flags: needinfo?(jmaher)
So the issue was that on bug 956388, the commit message accidentally included this bug number, so joel referenced the currently pending update.zip update.

Changing to the correct one (which landed 2013-11-28).

Nothing to see here, move along.
No longer depends on: 965731
You need to log in before you can comment on or make changes to this bug.