Closed Bug 944203 Opened 6 years ago Closed 4 years ago

[B2G][Settings] The string "Unplug USB cable to disable" is truncated

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g18 unaffected, b2g-v1.2 affected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g18 --- unaffected
b2g-v1.2 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: KTucker, Unassigned)

References

Details

(Keywords: regression, Whiteboard: dogfood1.2)

Attachments

(1 file)

Description:
The string "Unplug USB cable to disable" is truncated in English.

Repro Steps:
1)  Updated Buri to Build ID: 20131126004001
2)  Tap on the "Settings" icon.
3)  Tap on "Enable USB storage" to enable it.
4)  Plug the phone into the computer.
5)  Disable "USB storage" and look at the string under "Enable USB storage".

Actual:
The string "Unplug USB cable to disable" is truncated in settings.

Expected:
The string is not truncated.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131126004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/21e2ad082d85
Gaia: 264c6044b941437ac3c4b28fe4ca392d2bc78445
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

Notes:
Repro frequency: 100%
See attached: screenshot
VD fallout - probably isn't going to block. Don't worry about getting a regression range here.
This still exists on Buri with Build ID: 20140306134106, Platform Version: 30.0a1

I think this is a usability issue, since this is the only instruction re: finalizing disabling USB storage, and the word "disable" is what's cut off. May seem obvious, but without knowing exactly what unplugging does, the user might be a bit nervous about taking the leap.

"Unplug USB cable to di…"
This issue is still occur on Flame 3.0, 2.2, 2.1, and 2.0

The string "Unplug USB cable to disable" is truncated in settings. There is no way to view the entire string and as geo said in comment 2 could cause the end user to become nervous or confused about unplugging the cable.


Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150428002500
Gaia: 9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gecko: e79c19bf19bf
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150427001201
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 82a14be0462c
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150427000202
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: f700ee0a507d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner to take a look this is a long standing issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI UX to fine tune the message under "Enable USB storage".
Flags: needinfo?(gchang)
should fixed now. The discription will be changed to new line if overlap the switch
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.