[OTA][Data Migration][Internet sharing] "Wi-Fi hotspot" and "USB tethering" is disabled after update from v1.1 to v1.2

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: hlu, Assigned: gsvelto)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: permafail)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8339890 [details]
logcat.txt

* Build Information
Gaia:     92cd11ea023dd6598d82d859ae3c945ff6589ce6
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/14e91ab12441
BuildID   20131127004001
Version   26.0
ro.build.version.incremental=eng.cltbld.20131127.073824


* Reproduce Steps
1. Flash device to v1.1 build from PVT
2. Change update URL to http://update.boot2gecko.org/unagi/1.2.0/nightly/update_20131127004001.xml
3. Go to Internet Sharing configuration page under Settings.
4. Enable Wi-Fi hostspot and USB tethering,
5. Download the update package and install the update.

* Actual results:
1. "Wi-Fi hotspot" and "USB tethering" is disabled after update.

* Expected result:
1. All settings should be kept after update.
(Reporter)

Updated

4 years ago
Blocks: 944282
blocking-b2g: --- → koi?
Keywords: dataloss, regression
Hi Arthur, could you help to take a look? Thank you :)
Flags: needinfo?(arthur.chen)
blocking-b2g: koi? → koi+
Gabriele, could you help on this issue ?
Flags: needinfo?(gsvelto)
Sure, taking it.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)

Comment 4

4 years ago
Because 1.2 is going to be finished, should we mark this bug from koi+ to 1.3+? Thanks.
I've spent most of today trying to figure out this bug. I've traced the relevant settings in the SettingsService database and they are properly kept during an update (the b2g process sees the correct value set before the update) however it seems that the settings app is not picking up the values instead reverting to the default ones. I'm still not sure where the problem might lie, maybe a change in behavior somewhere within the SettingsService...
From what I'm seeing this is not a regression caused by the update, it happens even between reboots without updating the phone. When I enabled wifi tethering and then restart the phone the WifiWorker picks up the correct value of the 'tethering.wifi.enabled' preference (i.e. true) but somehow some other piece of code sets it to 'false' afterwards. I can see the call to the SettingsManager resetting 'tethering.wifi.enabled' to false but I haven't yet pinpointed where this is happening.

In the light of this I would suggest re-evaluating the koi+ status of this bug since I'm now pretty sure it was already present in 1.1 and thus is not a regression (I can reproduce it on 1.1 by just rebooting the phone w/o updating).
Flags: needinfo?(praghunath)
Fair enough, that sounds reasonable. Moving to blocking-.
blocking-b2g: koi+ → -
Flags: needinfo?(praghunath)
Keywords: dataloss, regression
(Reporter)

Comment 8

4 years ago
This issue is also happened in the updating from v1.0.1/v1.1 to v1.3
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(arthur.chen)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2][2.1-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.0-flame-test-run-2][2.1-flame-test-run-2] → permafail
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
We're definitely too late for fixing this one, closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.