Need to unplug device several times to connect

RESOLVED WORKSFORME

Status

DevTools
WebIDE
P3
normal
RESOLVED WORKSFORME
5 years ago
11 days ago

People

(Reporter: arnau, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-backlog])

My regular workflow is: (both nightly and unagi phone version  28.0a1, mac 10.9 and automaic ADB plugin)
1- make install-gaia
2- got to app manager and debug the app
3- fine tune the values in inspector and when I’m ok I do change my files in my editor.
4- go and do make install-gaia again to check I every thing is as I wanted.
5- If not fine tune again…

The thing is between 3 and 4, and 4 and 5, I need to unplug my usb at least twice for the terminar or browser to detect the device again.
And between 4 and 5 I have to shut down and restart Nightly, if not when clicking on debug nothing appears.

Thanks, and keep on helping us do our job with this awesome tool!

Comment 1

5 years ago
Arnau uses the ADB Addon.
Assignee: nobody → paul

Updated

5 years ago
Priority: -- → P1

Comment 2

5 years ago
Just a quick update: we found a fix for libadb. We might be able to integrate that into the ADB Addon Helper.

Updated

5 years ago
Blocks: 956871

Comment 3

4 years ago
Arnau, is this sill happening?
Flags: needinfo?(arnau)
Paul, unfortunately this is still happening.
Now without disconnecting the usb I can both use the terminal and see the device connected to the app manager. The thing is when I try to inspect the code by clicking on debug button, I see nothing there.
I will attach some captures to illustrate that.

What I've found out lately is if I do:

1-disconnect the usb after doing "make install-gaia"
2-close nightly
3-laung nightly again
4-open app manager
5-connect usb

Most of the times app manager detects my device, without having to connect the cable multiple time.
Flags: needinfo?(arnau)
Arnau, are you currently using the "ADB Helper 0.2.1" addon?

If so, we have a different version we are testing (based on libadb.js) that may resolve these issues.  Could you try it out?

This testing version, which describes itself as "adb helper 0.1" (even though it is actually newer...), is available here:

https://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator/adb-helper/adbhelper-mac.xpi

If that ends up leaving you worse off, you can revert back to "ADB Helper 0.2.1" from here:

https://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator/adb-helper/mac64/adbhelper-0.2.1-mac64.xpi
Flags: needinfo?(arnau)
:jryans, I've tested the new adb helper and I don't think is working better than the current one :(
Flags: needinfo?(arnau)
Well, it was worth a shot.

It's possible we may be able to resolve this issue with further updates to our ADB addons, but these issues are pretty tricky to resolve.  I'll try to look into this a bit more in the near future.

Longer term, we'll have support for debugging over Wi-Fi (bug 962308) which doesn't use ADB, so that's one way around this.
jryan & bdahl: returning to Arnau's steps to reproduce in comment 0, it looks like he has at least two distinct problems:

1. After using the App Manager, he has to replug the device multiple times in order for command-line ADB to detect it.
2. After using command-line ADB, he has to restart Firefox in order for libadb to detect the device.

#1 is presumably a bug in command-line ADB.  Theoretically we could fix this and push the fix upstream, although it'd still take a long time to get there.  So I wonder if there's a way to instead enable "make install-gaia" to use libadb if it's available.

#2 is the issue that once we shut down libadb (f.e. in response to a request from command-line ADB) there isn't a way to restart it.  That's a known problem that we should be able to address that in libadb/Firefox.

(A possible third problem is the need to replug the device multiple times in order for libadb to detect it.  We think we fixed that, although Arnau didn't notice an improvement.  But given the number of issues here, which can make it hard to notice such fixes, it's probably worth tackling the other issues first and then seeing if this one is still present.)
Flags: needinfo?(arnau)
(Cancelling errant needinfo request.  At this point I don't need any additional information.)
Flags: needinfo?(arnau)
Hey guys, looks like this is working great today, no need to disconnect the usb when switching from the app manager to the terminal :)
Using Nightly: 31.0a1
arnau: are you using the libadb-based ADB Helper addon or the non-libadb-based one, and did you update command-line ADB or your Android SDK installation?

I'm glad to hear it's working for you!  I'm just curious about what did it, so I'm looking for clues. :-)
not sure what's libadb-based/non-libadb-based I'm using the one downloaded from:https://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator/

An no updates, just the new nightly :)
I am also curious, like Myk! :)  If you go to the add-on manager, what version does it list for the ADB Helper?
Flags: needinfo?(arnau)
ADB Helper 0.2.1
Flags: needinfo?(arnau)
Hey guys, looks like there's been a regression today :(
I can not connect to App manager using ADB Helper 0.2.2.
It's not working either if I have 0.2.1 with Nightly 204-3-31

Comment 16

4 years ago
(In reply to Arnau March  [:arnau] from comment #15)
> Hey guys, looks like there's been a regression today :(
> I can not connect to App manager using ADB Helper 0.2.2.
> It's not working either if I have 0.2.1 with Nightly 204-3-31

Known issue. We're working on this. It should get better very soon.
(In reply to Paul Rouget [:paul] from comment #16)
> (In reply to Arnau March  [:arnau] from comment #15)
> > Hey guys, looks like there's been a regression today :(
> > I can not connect to App manager using ADB Helper 0.2.2.
> > It's not working either if I have 0.2.1 with Nightly 204-3-31
> 
> Known issue. We're working on this. It should get better very soon.

Version 0.2.2 already contains the fix for the recent promises issue.  Is there another fix that is upcoming?

My guess is that the original issue here has come back, but we don't have enough info yet to know why (or why it went away temporarily...).
Duplicate of this bug: 1045627

Updated

4 years ago
Blocks: 1070868

Updated

3 years ago
Assignee: paul → nobody
Duplicate of this bug: 1217642
Priority: P1 → P3
Whiteboard: [btpp-backlog]
I haven't seen this issue in a while.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Updated

11 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.