status bar shows host from another window in "Contacting host"

RESOLVED DUPLICATE of bug 94038

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 94038
17 years ago
16 years ago

People

(Reporter: Danek Duvall, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

I'm not sure what the name of this component is, but it's the bar at the
bottom of the browser, next to the taskbar, which shows the URL you'll
be taken to when clicking on a link, and shows progress, etc.  Please
update the summary with the correct component name, if there is one.

The problem is that it will often say it's contacting a host which has
nothing to do with the host you're trying to contact in the current
window, but instead is a host from which a web page was loaded in
another open window.

For instance, say I have slashdot and nytimes up in two different
windows.  I reload slashdot, and the bar at the bottom will say
"Contacting images.nytimes.com" even though the nytimes page is in a
different window, and may not even be downloading anything any more.

Reproducible: Sometimes
Steps to Reproduce:
Simply open two windows to different sites, and start loading and
reloading them.  The problem will appear shortly.

Expected Results:  This component should only have information that is pertinent
to the window to which it's attached, not to any other windows.

Comment 1

17 years ago
-> Networking
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → benc
Summary: taskbar host incorrect → status bar shows host from another window in "Contacting host"

Comment 2

17 years ago
I have experienced the same problem also. I think that what actually happens is
that the status bar shows the previous URL, eg. 

  1. open url on host A
  2. open url on host B
    -> status bar shows the last image/html/other's hostname (associated with
the load on step 1)

For example, I type "www.nasa.gov" on the URL-box, wait for it to load, then
type "www.mozilla.org" on the same browser window (and press enter), and *then*
the statusbar reads "Connected to www.nasa.gov".

(Reporter)

Comment 3

17 years ago
I haven't noticed that happen with multiple sites in the same window, as I tend to 
keep a different window open for each site I'm looking at.  But even with that, I
do notice that the status bar (thanks! I blanked on the term) has "Contacting
host" or "Transferring data from host" along with a hostname that belongs in the
status bar of another window, or really shouldn't be in any of the status bars,
because the page that host could belong to is already done loading.

Comment 4

17 years ago
I'm seeing this both on the NT talkback build of 0.9.3 and a hand rolled gcc-3.0
Linux athlon build of the same.

Comment 5

17 years ago
possible dup of bug 94038
(Reporter)

Comment 6

17 years ago
Yeah, I'll buy that this is a dup of 94038.  The problem seems to have gone away
once I quit using my proxy (FilterProxy), and the behavior looks the same.  I'll
leave it to the mozilla folks to actually mark it as a dup, though.

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 94038 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.