Closed Bug 944717 Opened 7 years ago Closed 7 years ago

Test failure "Successfully restarted in 32bit mode after requesting it - 'x86_64-gcc3' should equal 'x86-gcc3'" in /restartTests/testRestartChangeArchitecture/test3.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

x86
macOS
defect

Tracking

(firefox25 unaffected, firefox26 unaffected, firefox27 unaffected, firefox28 fixed, firefox29 fixed, firefox-esr17 unaffected, firefox-esr24 unaffected)

RESOLVED FIXED
Tracking Status
firefox25 --- unaffected
firefox26 --- unaffected
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed
firefox-esr17 --- unaffected
firefox-esr24 --- unaffected

People

(Reporter: mario.garbi, Assigned: whimboo)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(3 files, 1 obsolete file)

Something clearly changed in mozilla-central between the 28th and 29th of November.

mozilla-central pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3c44c1f43a67&tochange=1e3712793e7d

We have 2 merges from fx-team and 1 from inbound. I'll narrow this down with tinderbox builds.

Interestingly this doesn't fail with mozmill 2.0
Pushlog from fx-team:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=5a6373ab5fe6&tochange=514b65ab771d

I can't see how any of these changes could affect OSX restart flags...
I have doublechecked the builds I've tested, and this pushlog appears to be valid.
Please continue your regression tests. It's not done yet and those builds should still exist.
The referenced pushlog in comment 2 is from _consecutive_ tinderbox builds from fx-team.

I took them from https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-macosx64/ and the mentioned builds are:

1385679919 good
1385687659 bad

I'm not sure why there aren't tinderbox builds for each commit here.
Attached patch skip.patchSplinter Review
This fails a lot, and it seems that most of the tests failing with this error fails to send report document, so I think we should skip the tests ASAP.
Attachment #8341065 - Flags: review?(andreea.matei)
This was a single push as you can see only one user. So you will have to build Firefox then.
(In reply to Cosmin Malutan from comment #5)
> This fails a lot, and it seems that most of the tests failing with this
> error fails to send report document, so I think we should skip the tests
> ASAP.

Both have absolutely nothing to do with each other.
Comment on attachment 8341065 [details] [diff] [review]
skip.patch

Review of attachment 8341065 [details] [diff] [review]:
-----------------------------------------------------------------

Skipped:
http://hg.mozilla.org/qa/mozmill-tests/rev/51fe4371ac05 (default)
Attachment #8341065 - Flags: review?(andreea.matei) → review+
I've build Firefox on OSX several time already, but I haven't been able to have a `universal binary`.

I'm still tweaking the build options to have a correct build that supports both 32b and 64b architecture. I've looked at both https://developer.mozilla.org/en-US/docs/Mac_OS_X_Universal_Binaries and compared the compile flags from about:buildconfig
We should wait for bug 960509 being fixed before continuing the investigation.
Depends on: 960509
Andrei, I think we can re-enable those tests, also given that those were always working with Mozmill 2.0.
Flags: needinfo?(andrei.eftimie)
Attached patch 1.patch (obsolete) — Splinter Review
Great news.
I am unable to reproduce these failures at all with mozmill 2

Unskip patch attached.
Sample testrun:
http://mozmill-crowd.blargon7.com/#/functional/report/5c334d437fbb9f11a2de1d989b1b24ac

I'll check the other branches shortly
Assignee: nobody → andrei.eftimie
Attachment #8367197 - Flags: review?(andreea.matei)
Flags: needinfo?(andrei.eftimie)
Attached patch 1.1.patchSplinter Review
Applies cleanly to default and mozilla-aurora
Only those branches have had these tests skipped.

Small update to enable the tests in the manifest only for OSX
Attachment #8367197 - Attachment is obsolete: true
Attachment #8367197 - Flags: review?(andreea.matei)
Attachment #8367199 - Flags: review?(andreea.matei)
Comment on attachment 8367199 [details] [diff] [review]
1.1.patch

Review of attachment 8367199 [details] [diff] [review]:
-----------------------------------------------------------------

Why do we need a new patch for unskipping the test? We can simply backout. I do not see any differences in a local diff. Beside this the commit message should also contain better information which tests you re-enable.
Attachment #8367199 - Flags: review?(andreea.matei) → review-
Backed-out the skip patch on default and will do the same on other branches if no failures are present today.

http://hg.mozilla.org/qa/mozmill-tests/rev/fba803cf9d26
I'm not sure why we change the disabled line in the manifest for aurora but because of that difference to default, I cannot backout the patch. Andrei, can you please review?
Assignee: andrei.eftimie → hskupin
Attachment #8369095 - Flags: review?(andrei.eftimie)
Comment on attachment 8369095 [details] [diff] [review]
Unskip (aurora) v1

Review of attachment 8369095 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8369095 - Flags: review?(andrei.eftimie) → review+
Also landed on aurora, so the test is enabled across all platforms:
http://hg.mozilla.org/qa/mozmill-tests/rev/d263f5e26e79
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Henrik Skupin (:whimboo) from comment #18)
> Also landed on aurora, so the test is enabled across all platforms:
> http://hg.mozilla.org/qa/mozmill-tests/rev/d263f5e26e79

This missed the correct flag to only run tests on OSX in the manifest file.
I've fixed this during the merge in bug 964172
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.