Closed Bug 944801 Opened 6 years ago Closed 6 years ago

Collect UITelemetry on how many links are opened from the bookmarks menu button

Categories

(Firefox :: Toolbars and Customization, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- fixed
firefox28 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Depends on 1 open bug)

Details

(Whiteboard: [fixed-in-holly][good first verify])

Attachments

(2 files)

In order to measure bookmarks menu button usage, we want to count how many links are opened from it.
Whiteboard: [Australis:P1] → [Australis:P1][Non-Australis-Only]
BMB_bookmarksPopup:child should match any bookmark opened under the bookmarks menu button.
Attachment #8346104 - Flags: review?(gijskruitbosch+bugs)
Attachment #8346104 - Flags: review?(gijskruitbosch+bugs) → review+
Thanks Gijs! Landed on Holly as https://hg.mozilla.org/projects/holly/rev/b55bba3d7f25
Whiteboard: [Australis:P1][Non-Australis-Only] → [Australis:P1][Non-Australis-Only][fixed-in-holly]
Comment on attachment 8346104 [details] [diff] [review]
Patch v1 - for non-Australis

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

None. This gives BrowserUITelemetry the capability to count how many times bookmarks are opened from the bookmarks menu button.

User impact if declined: 

None.


Testing completed (on m-c, etc.): 

Only manual testing.


Risk to taking this patch (and alternatives if risky): 

None.


String or IDL/UUID changes made by this patch:

None.
Attachment #8346104 - Flags: approval-mozilla-beta?
Attachment #8346104 - Flags: approval-mozilla-aurora?
Removing Australis:P1 whiteboard tag because these already block an Australis:P1 and being redundant isn't helpful.
Whiteboard: [Australis:P1][Non-Australis-Only][fixed-in-holly] → [Non-Australis-Only][fixed-in-holly]
Attachment #8346104 - Flags: approval-mozilla-beta?
Attachment #8346104 - Flags: approval-mozilla-beta+
Attachment #8346104 - Flags: approval-mozilla-aurora?
Attachment #8346104 - Flags: approval-mozilla-aurora+
Whiteboard: [Non-Australis-Only][fixed-in-holly] → [Non-Australis-Only][fixed-in-holly][good first verify]
Whiteboard: [Non-Australis-Only][fixed-in-holly][good first verify] → [fixed-in-holly][good first verify]
Attachment #8346104 - Attachment description: Patch v1 → Patch v1 - for non-Australis
So it turns out this was remarkably easy. One caveat is that sometimes mouseups are fired for the "arrow" of the panel when after clicking on the dropmarker.

It's possible Enn's patch in bug 941409 will fix this, but if not, we're going to have to address this somehow. Worst case scenario, we'll need to subtract menu button clicks from the BMB_bookmarksPopup click count.

I'll file a separate bug for that.
Comment on attachment 8361676 [details] [diff] [review]
Patch v1 - for Australis

Almost... there...
Attachment #8361676 - Flags: review?(gijskruitbosch+bugs)
Attachment #8361676 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/736fa1afd493
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
[bugday-20140122]  - Could you please provide the exact STR(Steps to Reproduce) to check for fixed
Flags: needinfo?(mconley)
(In reply to svbabukumar from comment #11)
> [bugday-20140122]  - Could you please provide the exact STR(Steps to
> Reproduce) to check for fixed

Sure, here goes:

1) In Nightly, open about:telemetry and ensure Telemetry is enabled. If not, enable and restart the browser.
2) Click on the right side of the Bookmarks menu button to bring up the list of bookmarks.
3) Click on a bookmark.
4) Repeat steps 2 and 3 any number of times
5) Open about:telemetry, and expand the "Simple Measurements" section.
6) There should be a row labeled "UITelemetry". On the right half of that row is a big JSON blob. You're looking for and entry in that blob called "BMB_bookmarksPopup". The entry should be a key, mapped to an object that will hold the count of how many times a bookmark has been clicked from the popup with each mouse button.

So, for example, if you clicked on 15 bookmarks in the popup with the left mouse button, and right-clicked one of those bookmarks once, you'd see:

BMB_bookmarksPopup: {
  left: 15,
  right: 1
}

And that's it!

Let me know if you have more questions.
Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.