Homescreen has shrunk to cards view size - css pollution?

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 8340788 [details]
screenshot 1

I apologise in advance that I do not know how I got the device into this state, but it is my daily device and had been up for over 8 days when it occurred. I know it is an older build too but similarly the continuous uptime is important to find dogfooding bugs like this.

The homescreen panels have shrunk to what appears to be the size of the cards view.

The homescreen is functional and app can be swiped, but the icon location corresponds with where they *should* be on the screen, not where they actually are.

The icons in the dock do not work.

All other apps work fine and display at their normal size.

For some reason I cannot connect to the device with the app manager (to inspect the HTML). I'll try not to reboot it in case there is any further debugging I can do on it - please let me know asap!

Device: Peak
Gaia commit: 2013-11-13 > c6526ade
(Reporter)

Comment 1

5 years ago
Created attachment 8340789 [details]
screenshot 2
(Reporter)

Comment 2

5 years ago
Created attachment 8340790 [details]
context menu screenshot

Updated

5 years ago
Component: Gaia::System → Gaia::System::Window Mgmt
Looks like weather is too cold.

Do you see anything wrong in logcat?
(Reporter)

Comment 4

5 years ago
It's shrunk!

The device was up for 2 more days before I could get to a computer with adb so anything in logcat is long gone :(
(Reporter)

Comment 5

5 years ago
I've replicated this again on:

Device    Peak
Gaia      4a5608657b5a0a12be8d69af973483bc9a6b6278
Gecko     d2ef16927622a687998c32093cc80d5357620a14
BuildID   20140211065551
Version   30.0a1

(did not catch a screenshot this time)
(Reporter)

Comment 6

5 years ago
Created attachment 8379003 [details]
2014-02-19-23-23-44.png

In this scenario the passcode is shown inside the lockscreen.

The passcode area can be moved up and down as if it is jammed in half cards view/half lockscreen view.

Sorry no logcat, it's a user build and my dogfood phone so I had to reboot to get it working again.


Device Peak
Gaia      4a5608657b5a0a12be8d69af973483bc9a6b6278
Gecko     d2ef16927622a687998c32093cc80d5357620a14
BuildID   20140211065551
Version   30.0a1
I just reproduced this on Desire Z, I think it was after running Royal Solitaire.

Comment 8

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.