webgl-draw-buffers.html conformance test failures

RESOLVED FIXED in mozilla28

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jrmuizel, Assigned: Guillaume Abadie)

Tracking

unspecified
mozilla28
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 affected, firefox28 affected)

Details

(Whiteboard: webgl-driver)

Attachments

(1 attachment)

(Reporter)

Updated

4 years ago
Blocks: 936246
(Reporter)

Comment 1

4 years ago
Guillaume, do you see these failures as well? If you do, do you have time to take a look at them?
Flags: needinfo?(guillaume.abadie)
(Assignee)

Comment 2

4 years ago
Hi Jeff! =) I don't have any on Firefox 26, but I'm compiling the latest morzilla-central right now...
Flags: needinfo?(guillaume.abadie)
(Assignee)

Comment 3

4 years ago
(In reply to Guillaume Abadie from comment #2)
> Hi Jeff! =) I don't have any on Firefox 26, but I'm compiling the latest
> morzilla-central right now...

Mozilla-Central* sorry :)
(Assignee)

Comment 4

4 years ago
Oh... That is unfortunate... I'm having to many build error while trying to build on 10.9, and the campus' internet connection is to slow to download Firefox from the FTP right now (in fall 2013... -_-'). Will try tomorrow at the department!
FAIL getError expected: INVALID_ENUM. Was NO_ERROR : should not be able to attach pass the max attachment point: gl.COLOR_ATTACHMENT0 + 8
(Reporter)

Comment 6

4 years ago
(In reply to Benoit Girard (:BenWa) from comment #5)
> FAIL getError expected: INVALID_ENUM. Was NO_ERROR : should not be able to
> attach pass the max attachment point: gl.COLOR_ATTACHMENT0 + 8

BenWa gets this on 10.9

on 10.7 I also get:

--------- draw tests -----------
fragement shader
PASS gl.checkFramebufferStatus(gl.FRAMEBUFFER) is gl.FRAMEBUFFER_COMPLETE
PASS gl.checkFramebufferStatus(gl.FRAMEBUFFER) is gl.FRAMEBUFFER_COMPLETE
test that each texture got the correct color.
FAIL attachment 0 should be 255,0,0,0
at (24, 56) expected: 255,0,0,0 was 0,0,0,0
FAIL attachment 1 [details] [diff] [review] should be 0,255,0,0
at (2, 4) expected: 0,255,0,0 was 0,0,0,0
FAIL attachment 2 [details] [diff] [review] should be 255,255,0,0
at (4, 28) expected: 255,255,0,0 was 0,255,0,0
FAIL attachment 3 [details] [diff] [review] should be 0,0,255,0
at (12, 0) expected: 0,0,255,0 was 0,0,0,0
FAIL attachment 4 [details] [diff] [review] should be 255,0,255,0
at (28, 12) expected: 255,0,255,0 was 0,0,255,0
FAIL attachment 5 [details] should be 0,255,255,0
at (8, 20) expected: 0,255,255,0 was 0,0,0,0
FAIL attachment 6 [details] should be 255,255,255,0
at (10, 11) expected: 255,255,255,0 was 255,255,0,0
FAIL attachment 7 [details] should be 0,0,0,255
at (52, 2) expected: 0,0,0,255 was 0,0,0,0
Gross. We'll have to dig a little into this, but the 10.7 failures sound like we should just blocklist it.
The error on 10.9 is easy enough to work around.
Whiteboard: webgl-driver
(In reply to Jeff Muizelaar [:jrmuizel] from comment #6)
> (In reply to Benoit Girard (:BenWa) from comment #5)
> > FAIL getError expected: INVALID_ENUM. Was NO_ERROR : should not be able to
> > attach pass the max attachment point: gl.COLOR_ATTACHMENT0 + 8
> 
> BenWa gets this on 10.9
> 

... and on 10.8 with 'AMD Radeon HD 6750M 1024 MB' early 2011 MBP
(Assignee)

Comment 9

4 years ago
Have found the bug :

http://dxr.mozilla.org/mozilla-central/source/content/canvas/src/WebGLFramebuffer.cpp#507

it is suppose to be a >= not >
(Assignee)

Comment 10

4 years ago
Could I be assigned on this bug, and let me a little while for compiling firefox on 10.9 ? Thanks !
(Assignee)

Comment 11

4 years ago
Created attachment 8342970 [details] [diff] [review]
patch revision 1

Here is the patch.

Push to try : https://tbpl.mozilla.org/?tree=Try&rev=7923b44458f4
Attachment #8342970 - Flags: review?(jgilbert)
Comment on attachment 8342970 [details] [diff] [review]
patch revision 1

Review of attachment 8342970 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome. I love when the issue is so simple.
Attachment #8342970 - Flags: review?(jgilbert) → review+
I believe this is what's affected.
status-firefox26: --- → unaffected
status-firefox27: --- → affected
status-firefox28: --- → affected
(Assignee)

Comment 14

4 years ago
(In reply to Jeff Gilbert [:jgilbert] from comment #12)
> Comment on attachment 8342970 [details] [diff] [review]
> patch revision 1
> 
> Review of attachment 8342970 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Awesome. I love when the issue is so simple.

My Pleasure! Surly my smallest patch ever! =)

https://hg.mozilla.org/integration/mozilla-inbound/rev/701c8c3fb409

We keep in touch for any other small regression like that I can do aside of my university projects! =)
https://hg.mozilla.org/mozilla-central/rev/701c8c3fb409
Assignee: nobody → guillaume.abadie
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
You need to log in before you can comment on or make changes to this bug.