When fastload enabled, JS errors and gray windows

RESOLVED DUPLICATE of bug 93558

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 93558
17 years ago
16 years ago

People

(Reporter: Martin Poirier, Assigned: brendan)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Win98SE, mozilla build 2001080804

Steps to reproduce

1. Enable fastload by adding 
user_pref("nglayout.debug.disable_xul_fastload", false);
in the prefs.js file

2. Start mozilla

3. Bring up the javascript console, look at the window.

4. The window is grey and all buttons are non-responsive.(screenshot coming)

5. The same happens with the bookmarks editing window, but history is OK.

6. In preferences|advanced, disable and re-enable javascript for navigator.

7. Bring up the javascript console again. This time the console is OK and shows
an error :


Error: bc has no properties
Source File: chrome://global/content/console.js
Line: 90

8. This doesn't happen without enabling fastload


Result: javascript console and bookmarks editing windows greyed-out
Expected result : javascript console and bookmarks editing windows loading fine
on first attempt and no 

Error: bc has no properties
Source File: chrome://global/content/console.js
Line: 90 

in the console
(Reporter)

Comment 1

17 years ago
Created attachment 45249 [details]
screenshot showing greyed-out Js console
(Assignee)

Comment 2

17 years ago
Martin, did you apply the patch in bug 68045?  FastLoad doesn't work correctly
without it, last time I checked.  QA-contacting jrgm for confirmation.

/be
Assignee: rogerl → brendan
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: pschwartau → jrgm
(Reporter)

Comment 3

17 years ago
No I didn't apply the patch, and don't know how. Do you see this problem while
uning the patch ?. I think that it would be easier to check for yourself than to
begin explaining me hoy to apply the patch... :)

BTW, problem still occurs on this morning Win32 build 2001080904

Comment 4

17 years ago
I've seen this happen without enabling the pref. I believe this is another 
aspect of the general problem noted in bug 93558, which seems to be 
independent of fastload [although does come "close" in that xul resources
are not being loaded from jar files].

(And to confirm, without applying the patch in bug 68045, fastload doesn't work
correctly, although if the pref is on, then you will travel its code paths).
(Assignee)

Comment 5

17 years ago
Then, as I suspected, this is not my bug.

/be

*** This bug has been marked as a duplicate of 93558 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.