Closed Bug 945360 Opened 6 years ago Closed 6 years ago

Fix three recently added hazards in spidermonkey

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla28
Tracking Status
firefox28 --- fixed

People

(Reporter: terrence, Assigned: terrence)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Pretty much trivial.
Attachment #8341194 - Flags: review?(sphink)
Comment on attachment 8341194 [details] [diff] [review]
fix_new_hazards_in_sm-v0.diff

Review of attachment 8341194 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/vm/Debugger.cpp
@@ +709,5 @@
>  
> +        if (obj->is<JSFunction>()) {
> +            RootedFunction fun(cx, &obj->as<JSFunction>());
> +            if (!EnsureFunctionHasScript(cx, fun))
> +                return false;

Is this the same one I just r+'ed for jonco too? You may get a conflict.
Attachment #8341194 - Flags: review?(sphink) → review+
I thought that was me and I thought I had checked that in. Probably got dropped between tree closers with all the bustle at the hack week.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f8b57cbe128a
Duplicate of this bug: 944661
https://hg.mozilla.org/mozilla-central/rev/f8b57cbe128a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.