JavaScript Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXULChromeRegistry.getSelectedLocale]

VERIFIED DUPLICATE of bug 945750

Status

()

--
blocker
VERIFIED DUPLICATE of bug 945750
5 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: rnewman)

Tracking

({regression, reproducible})

Trunk
ARM
Android
regression, reproducible
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox28 affected)

Details

(Reporter)

Description

5 years ago
Unable to visit query a website, view search results or actually do anything productive with the web browser.

E/GeckoConsole( 5187): [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXULChromeRegistry.getSelectedLocale]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/nsURLFormatter.js :: nsURLFormatterService.prototype._defaults.LOCALE :: line 92"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/nsURLFormatter.js" line: 92}]
(Reporter)

Comment 1

5 years ago
Another related error 

E/GeckoConsole( 5187): [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXULChromeRegistry.getSelectedLocale]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/TelemetryPing.js :: getLocale :: line 53"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/TelemetryPing.js" line: 53}]
Impressive that we managed to break things this badly and still pass tests.
Flags: in-testsuite?
(Assignee)

Comment 3

5 years ago
Srsly. 

Puzzling that this was working for me, and the people I had test it, not long before it landed.
(Reporter)

Comment 4

5 years ago
Noted in channel that this affected multi-locale build the most, and I am told that our automation tests against en-US.
(Assignee)

Comment 5

5 years ago
Which device and OS version?

Which system locale?

This was pretty extensively hand-tested against multi-locale builds before it landed, so either we screwed that up somehow, someone landed something else in the mean time that broke things, or there's some kind of environmental difference.
Flags: needinfo?(aaron.train)
(Assignee)

Comment 6

5 years ago
Ugh, of course nsChromeRegistryChrome.cpp digs around in prefs and does locale-related stuff. Of course.

/me attempts to reproduce.
(Reporter)

Comment 7

5 years ago
* LG Nexus 4 (Android 4.4), English (United States)
* LG Nexus 5 (Android 4.4), English (United States)
* Samsung Galaxy Tab 2 7" (Android 4.2.2), English (United States)

Finkle saw it too.
(Assignee)

Updated

5 years ago
See Also: → bug 945750
I'm on a Samsung Galaxy S4 SCH-I545 running Android 4.3, English (United States) and can reproduce this also.
(Assignee)

Comment 9

5 years ago
As far as we can tell, this is still broken after backing out my bug. (And I still can't reproduce it.)
(Assignee)

Comment 10

5 years ago
Merged backout to fx-team to avoid confusion:

https://hg.mozilla.org/integration/fx-team/rev/4bf430d990e5
(Assignee)

Updated

5 years ago
Depends on: 945750
I opened the Nightly APK, then opened assets/omni.ja and found zero locales in the "chrome" folder. If you do the same with a working Nightly from a few days ago, you'd see a long list of locale folders. The chrome.manifest file also fails to list the locales.

Something has broken the multi-locale repack.
(Reporter)

Comment 12

5 years ago
Apologies for the blind block; I saw getSelectedLocale and falsely assumed it was bug 936756
No longer blocks: 936756
Flags: needinfo?(aaron.train)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945750
No longer depends on: 945750
(Assignee)

Comment 14

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #12)
> Apologies for the blind block; I saw getSelectedLocale and falsely assumed
> it was bug 936756

It was a good call; better to err on the side of backing out!
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.