Closed Bug 945765 Opened 6 years ago Closed 6 years ago

Add some basic apzc tests to catch regressions

Categories

(Firefox for Metro Graveyard :: Tests, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(firefox28 verified, firefox29 verified)

VERIFIED FIXED
Firefox 28
Tracking Status
firefox28 --- verified
firefox29 --- verified

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [beta28] p=1 [qa-])

Attachments

(1 file, 2 obsolete files)

No description provided.
Summary: Add some basic apzc test to catch regressions → Add some basic apzc tests to catch regressions
Blocks: metrov1it21
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [beta28] p=0
Whiteboard: [beta28] p=0 → [beta28] p=1
Attached patch two basic apzc tests v.1 (obsolete) — Splinter Review
Attached patch two basic apzc tests v.1 (obsolete) — Splinter Review
Attachment #8344794 - Attachment is obsolete: true
Comment on attachment 8344795 [details] [diff] [review]
two basic apzc tests v.1

Fixing this for good and adding some tests. (Note the tests rely on native events from bug 941774.)
Attachment #8344795 - Flags: review?(mbrubeck)
Comment on attachment 8344795 [details] [diff] [review]
two basic apzc tests v.1

argh! wrong bug/patch.
Attachment #8344795 - Flags: review?(mbrubeck)
Attachment #8344795 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/4ad9d2b82a4c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Comment on attachment 8345930 [details] [diff] [review]
basic apzc tests v.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no regression, adding some test coverage for apzc.
User impact if declined: none.
Testing completed (on m-c, etc.): yes.
Risk to taking this patch (and alternatives if risky): none.
String or IDL/UUID changes made by this patch: none.
Attachment #8345930 - Flags: approval-mozilla-aurora?
Attachment #8345930 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: Firefox 29 → Firefox 28
Could anyone give some guidelines for the QA to verify this? Thanks!
Flags: needinfo?(jmathies)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #9)
> Could anyone give some guidelines for the QA to verify this? Thanks!

This bug is just adding automated tests, so there's no manual testing needed...  I took a look at the m-c build logs on https://tbpl.mozilla.org/?tree=Mozilla-Aurora and https://tbpl.mozilla.org/ and verified that the new test file (browser_apzc_basic.js) is running in the Win8 "mc" test jobs.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jmathies)
Whiteboard: [beta28] p=1 → [beta28] p=1 qa-
Whiteboard: [beta28] p=1 qa- → [beta28] p=1 [qa-]
You need to log in before you can comment on or make changes to this bug.