All users were logged out of Bugzilla on October 13th, 2018

Opus in WebM ignores SeekPreroll

RESOLVED FIXED in mozilla29

Status

()

RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: j, Assigned: j)

Tracking

Trunk
mozilla29
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
SeekPreroll is currently ignored, the webm decoder should use the SeekPreroll value provided by libnestegg while seeking to avoid clicking sound.
(Assignee)

Updated

5 years ago
Depends on: 938686
(Assignee)

Comment 1

5 years ago
Created attachment 8345196 [details] [diff] [review]
0001-Handle-CodecDelay-and-SeekPreroll.patch

- handle codecdelay
- handle seekpreroll
- fix bug where wrong number of channels was passed to AudioQueue causing cracking sound on seek.
Attachment #8345196 - Flags: review?(kinetik)
Attachment #8345196 - Flags: review?(kinetik) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3b6dfc1090b0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Updated

4 years ago
Depends on: 1034081

Updated

3 years ago
Depends on: 1182821

Comment 4

3 years ago
This should be backed out. There are two dependency anoyng bug caused by this bug.
Because, this is not blocked any other Bug. So I think backing out is best way to resolve these problem.
(Assignee)

Updated

3 years ago
No longer depends on: 1182821

Updated

3 years ago
Depends on: 1182821
You need to log in before you can comment on or make changes to this bug.